After migration keepass databases not open

Usually the keepass app is launched with the keepass file by clicking. After moving to a new server, the browser is downloading the keepass file.

Nextcloud version (eg, 12.0.2): 13.0.4
Operating system and version (eg, Ubuntu 17.04): Debian 4.9.88-1
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.25
PHP version (eg, 7.1): 7.0.27-0+deb9u1

Is this the first time you’ve seen this error? (Y/N): yes, after migration

The output of your Nextcloud log in Admin > Logging (nothing more):

File accessed: "/_Zugang/xyz.kdbx"

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'yyy',
  'passwordsalt' => 'xxx',
  'datadirectory' => '/var/oc-data',
  'version' => '',
  'dbtype' => 'mysql',
  'dbname' => 'yyz',
  'dbuser' => 'xyz',
  'dbpassword' => 'xyz',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'installed' => true,
  'loglevel' => 0,
  'theme' => '',
  'maintenance' => false,
  'trusted_domains' =>
  array (
    0 => 'mydomain1.tld',
    1 => 'mydomain2.tld',
  'secret' => 'xxx',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'trashbin_retention_obligation' => 'auto',
  'updatechecker' => false,
  'appstore.experimental.enabled' => true,
  'overwrite.cli.url' => 'https://mydomain1.tld/owncloud',
  'htaccess.RewriteBase' => '/owncloud',
  'updater.secret' => 'xx',

Apache is not logging any errors for that domain.

As far as I know the NC Keepass app has not yet been migrated to 13.x.

Yes, MIkeLupe, that’s right. I forgot that.

In my case it worked on version 13 quite long, by increasing the max-version in the info.xml. The reason, why the developer decided not to put on version 13 is a bug, which describes my issue.

I don’t know why nextcloud was able to open the kdbx files with keeweb on my old server. Seems to be luck. Maybe a file scan on the new server broke the mime type adjustment.

Here is the bug:

Its very sad. The combination of nextcloud, keepass and keeweb was very usefully.

So true :-/

Well, it is still and the app works just as well as on NC 12, but the developer decided to stop development until the Mimetype problem is solved upstream. :frowning_face: To open Keepass databases, there is a temporary fix that has to be applied after each update, but the dev does not like this fix: