Adding Firefox Extension

For the life of me I cannot find information on what to enter into the “Url” field when setting up Passwords extension in Firefox. If you know where to find this, please share a link.


You need to enter the URL which you usually use to access Nextcloud.
So if your Nextcloud is hosted at “” you need to enter that.

1 Like

Hi when I try to enter URL and credentials I get the following error message:

JSON.parse: unexpected character at line 1 column 1 of the JSON data

Same for me, have you solved this issue?

Please make sure that your password is correct.
Please also make sure that “Enable Legacy API” is enabled in the admin settings.

why using the old API? It’s a new installation (nextcloud 15.0.2 and firefox 64.0.2 and passwors addon The android client communicate with the server. It’s a problem with firefox, maybe character encoding.

@konki The browser extension is older than the passwords app for Nextcloud and still relies on the api of the passwords app for OwnCloud. I will migrate it to the new api after i have finished the work on the client side encryption.

There was indeed an error with special characters in the password or username. This has been fixed in 1.8.0.

Thank you for your reply. I activated the old API on my nextcloud instance (nextcloud 15.0.2, firefox 65.0.1 and passwords addon The android client still communicates with the server but the firefox addon passwords can’t find the server.

it seems to be a matter of either/or… either you use the old api and thus ff-addon seems to stay usable. or you disable old api and could use android app while ff-addon would stop working.


The Firefox extension requires the old api to be enabled since it is built to use it.
If you have the old api enabled you can still use any app that uses the new api.

@konki if the Firefox extension fails to connect, there should be a more detailed error message in 1.8.0. Do you get an error?

umm my freshly installed android app (yesterday!) could connect to the server but couldnt retrieve and information from passwords. any. so i just turned off the old api and — swooch - it worked like a charm.

running android 9.

update: now - after the initial connect and retrieving data for the first time - android app works, even if i am using old api again…