Add remote file storage as local storage

Hey there. I’m using the docker image of NextCloudPi. I mounted my Synology on my Linux server on /mnt. The whole NCP instance is stored on the NAS attached to my Linux server and mounted as well.

How am I possible to use the mounting of the Synology as it would be a regular folder of the NAS device attached to the server. Or at least no external folder. I would like to create group folders out of the Synology space.

My compose:

    restart: always
    container_name: nextcloudpi
    image: ownyourbits/nextcloudpi-arm64:latest
      - 80
      - 443
      - 4443
      - /media/storage/data:/data
      - /etc/localtime:/etc/localtime:ro
      - nextcloudpi

Should I just mount the Synology like:
- /mnt:/synology-data

Nextcloud uses it’s own storage schema within file root (default is /var/www/html/data, maybe NextcloudPi is different). Within this file root it creates folders for every user and group folder. If you just mount your local data to a random folder structure it will simply not use it.

You could mount the NAS data to some docker folder and configure this folder as “local mount”. In general you may experience problems when files under control of Nextcloud are edited (created/moved/deleted) through other applications. Maybe the best way is to separate data stored in NC and NAS (Samba/FTP…) and not mix the access methods…

I know. I added the folder as an external folder in Nextcloud now with the type local and the folder does simply not show up and I have no idea why. I’ve mounted the folder just like I said in my question as synology-data and it is there in the container because I can access it and also Nextcloud is not complaining about anything and finds the folder to add but still, the folder isn’t there.

I don’t get what you mean by

how did you mount the folder? with docker or with Nextcloud external storage?

Anyway, it is a bug of Nextcloud:

I did everything right but if you got the terms of service app enabled it simply does not work and is buggy.