Add button disabled in "Files/All files" no file upload possible after clean istall

I am running Nextcloud as a TrueNas App
Nextcloud version (eg, 20.0.5): App Version: 28.0.2
Operating system and version (eg, Ubuntu 20.04): TrueNAS-SCALE-
Apache or nginx version (eg, Apache 2.4.25): Chart Version: 2.0.3 (Black Box)
PHP version (eg, 7.4): black box

The issue you are facing:
After a clean install off the TrueNas App version the user setup was no problem. The istallation of the calender app was without any problem. But all users including the admin do not have a Button (+ Add) enabled in the All files view

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Install TrueNas App version above
  2. Login with the admin account.
  3. try to upload a file

There is no error shown

Is there anybody out there how has the same problem?
Any tip how to enable the “+ Add” button?

It shouldn’t be an + Add button; when functioning it’s an + New button. If you hold your cursor over it, does it say something like “You don’t have permission to upload or create files here”?

I have the same problem, how to solve it?

Yes thats what is written when I hover overt the Add button

“You don’t have permission to upload or create files here”.
When I look at the file System all rights to the directory is fully open:

drwxrwxrwx 4 www-data www-data     4 Feb 16 20:08 Martin

So I don’t know where to add the permission.

i have the same issue i can login and do everything except add files.

im running on lxc debian 12 in docker. when i look in my data directory i do see my user and stuff created and even files in there. just cant add more

Although I don’t have a solution, I’ve found the cause of my problem. I run my Nextcloud installation on a TrueNas Scale behind an “Nginx Proxy Manager” docker solution on a separate server. When I want to access Nextcloud, I do it via:

The Nginx Proxy Manager forwards the request to my TrueNas server as:

In the configuration, I specify:

Nextcloud host:
The rewrite port is: 443

In this configuration, I can log into Nextcloud without any problems using However, adding a file is not possible. I also cannot access the files provided by default during installation.

If I change the configuration to:

Nextcloud host: (local home network server address)
without rewrite address

I can access the nextcloud using:
The upload is possible. The disatvantage is that I only can access the nextcloud from my local home network. :smiling_face_with_tear:

What do I have to change to be able to upload (add and access) files through the “nginx proxy manager”

Unfortunatelly the config.php was not posted, as it was asked for at creation of the start-posting of this thread.

$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    1 => 
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
  'overwritehost' => '',
  'overwriteprotocol' => 'https',
  'trusted_proxies' => 
  array (
    0 => '',
    1 => '',
    2 => '',
    3 => '',
    4 => 'nginx-raspi',
  'upgrade.disable-web' => true,
  'passwordsalt' => 'chaned/cJBTLa+v8ov',
  'secret' => '17acLStNw4e+changed',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => '',
    2 => '',
    3 => '',
    4 => 'nginx-raspi',
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'pgsql',
  'version' => '',
  'overwrite.cli.url' => 'https://localhost',
  'dbname' => 'nextcloud',
  'dbhost' => 'nextcloud123-postgres:5432',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_admin',
  'dbpassword' => 'changed',
  'installed' => true,
  'instanceid' => 'ocqr94nvttkf',

Please remove the secret data (password salt, “secret”, dbpassword)

Is there the domain mentioned, you call but the “Add” button does not work?

no it was not. but I added It:

without any change in the result

The requests in the nextcloud are coming from an IP 172.0.x.x. I do Not have a clou why this ist the fact. But after adding this IP to the trustet list it ist working.