Accessing the server from an untrusted domain - button points to wrong address

I set up my Nexcloud Box. Then I accessed via SSH and set a static ip.

Now my Nextcloud Box still thinks it is at its old ip address (see image).

After a reboot, when I try to access my Nextcloud Box from my laptop machine I get the dreaded “You are accessing the server from an untrusted domain”. This is weird because just before I switched the ip address from 192.168.2.202 --> 192.168.2.10 everything worked just fine.

If I press the “Add 192.168.2.10” as trusted domain" button (see image) everything just hangs. It is because the button is trying to go to its old ip: 192.168.2.202 . :neutral_face:

Which setting do I need to update in order to fix this issue? Can this be fixed in the web GUI? If not, can someone provide the path to the files to edit?

Note: I am on a Nextcloud Box.

Thanks :slight_smile:

More info:

I updated the ip address of the Nextcloud Box by editing the /etc/network/interfaces file.

Is there a different way I should have changed the ip address?

The automated adding only works if the primary trusted_domain is working. You changed the ip address of your device (which is one solution) but you can also add trusted_domains in your config/config.php.

how did you edit that file

ok I used vi but could see what to edit, I changed routers and now cannot get other computer to see nextcloud

Hi all,

I have several sub domains, and my NC sub domain is on the same server.
I know how to add the sub domain into the config.php.
For example:



https://def.xyz.com

If the users go to the wrong sub domain, it’s should re-direct to https://cloud.xyz.com or don’t see that warning message.

My question are:

  1. How do I disable the message “You’re accessing the untrusted domain”?

  2. Can I re-route it to the correct one ?