Access via webdav with WinSCP

Hi All,

Trying to access my files via webdav with WinSCP, but getting a 405 “Method not Allowed” error.

I understand that WinSCP needs to communicate with, but if I enter that value as the “Host name” in WinSCP, I suspect that it requests a directory listing for /nextcloud/remote.php/dav/files// from, but of course the root url doesn’t implement webdav. WinSCP needs to issue requests to the full path, but I can’t figure out how to make it do so.

There’s a number of posts on this forum suggesting using WinSCP, but none mention this issue.

The nextcloud docs explain how to access via cyberduck, but no mention of WinSCP.

There’s a number of posts on the WinSCP forum, acknowledging that you’ll get a 405 error if requests are made to the root URL, and there’s a RootPath setting to specify the path that requests should be issued to, but I can’t see anywhere to specify that RootPath setting via the UI.

I can’t use a workaround like mapping it at as network drive, or cyberduck, because I’m trying to access from a corporate desktop with no administrator access, and WinSCP is likely the only option because I can use a portable / standalone app.

Thanks in Advance.

The same settings that work in one WebDAV client should work in another, provided there isn’t a bug involved.

Are you using the WebDAV URL displayed under the gear at the bottom left?

Can you connect with a different client to confirm settings are correct?

I think the url should be:


Thanks so much for taking the time.

I did indeed have the wrong URL, I had “googled it”, and must have been looking at docs for a prior version.


1 Like

Actually for me the url displayed in files app settings is not working, it says:


which is creamy bs obviously…

I have also used /nextcloud/remote.php/webdav for long with nautilus bookmarks.

Url under the gear not working correctly. What is it for?