Access through untrusted domain

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2):
Operating system and version (eg, Ubuntu 19.10):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1):

The issue you are facing:
Getting error as " Access through untrusted domain" when I am trying to access the nextcloud through IP address.

Is this the first time you’ve seen this error? (Y/N):Y

Steps to replicate it:

  1. https://
  2. Access through untrusted domain

Please contact your administrator. If you are an administrator, edit the “trusted_domains” setting in config/config.php like the example in config.sample.php.

Further information how to configure this can be found in the documentation.
3. With machinename instead of IP, working fine.But machine name won’t be accessible with all devices, example: with non-windows clients

With the documentation link provided in the output, I tried to add trusted hosts(which should not be in production) but I am getting read-only error even for root account.

If you are an administrator, edit the “trusted_domains” setting in config/config.php like the example in config.sample.php.

that should give you a clue, doesn’t it :wink:

if you want to access it via your ip, add it to the config.php under trusted domains.

Thanks for the reply.

Can you please answer to the last line also.

In the config file, when I added the IP address of my server machine, it is accepting.
But, when the IP changes, again I need to add.
Can’t we just white list the server to login with its ip even its ip changes?

Why should your IP address change? If you are on DHCP then switch to static IP, we are dealing with a Server after all.
And why cant your non Windows devices not resolve the DNS Name of the thing? I would search there for a start. I dont think the Trusted domain setting will accept wildcards.

My honest recomendation is to stop trying to put the cart before the horse, if you know what i mean. You have very simple config issues in your network, you should fix it there, not inventing some bogus hack in the config.php

1 Like

Static is not a valid solution, you would know this if you are working with windows AD environments.

No, just no. Beeing in Enterprise IT Infrastructure for 12 Jears now,… NO!

I really mean no offense, but put the overconfidence in your skills aside and get your basics straight. Start with Internet Protocol for that matter.

Thanks in advance.

Ascendancer out.


When I say we can’t set static IP, it doesn’t mean/ you can’t assume that I have 0 knowledge on Networking.

And, I can’t explain my complete environment.

So, if you have a solution then please comment or else let others reply instead of killing the thread.

the concept of servers with a non-static ip do sound rather strange to me, i’d agree to @Ascendancer.

but wells… if you “can’t explain [your] complete environment” you prolly won’t get any other helpful hints than perhaps: you need to fill in all possible ip-addresses your server could get as trusted domains to config.php beforehand.

good luck

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.