"Access through untrusted domain" when trying to acces with domain name

Hello guys,

i have installed nextcloud on my rasberry pie following this guide:


also I have a domain name

As of now, when I try to access the cloud outside the local network I get the “Access through untrusted domain” error.

I-ve checked multiple times my config.php, and as of now I think I have the trusted domain correct as follow>

> 'trusted_domains' => 
>   array (
>     0 => 'localhost',
>     1 => '192.168.x.xx',
>     2 => 'https://93.55.xxx.xxx/nextcloud',
>     3 => 'https://www.xxxxxxxx.cloud/nextcloud',

Unfortunately I still get the error.

Do you have any suggestion on what I could try _

thank you very much


Is this your domain from outside?

I have only the IP or URL without http or HTTPS://

Perhaps check your vaule:


thank you for the replies.

I was able to fix it last night.
instead of:

3 => ‘https://www.mydomain.cloud/nextcloud

I used:

3 =>’ www.mydomain.cloud/nextcloud’

The same for the ipv4, no need to put ‘https://’ infront.

Hope it can be useful to others as well.

exactly, that was the mistake.
Thank you :slight_smile:

1 Like

Hey guys i added my url to the trusted domain and it is still not working. I am using a reverse proxy to access my local host. I am using ngrok