Access reverse-proxied nc directly in local network


After some problems, I managed to get nextcloud working behind a reverse proxy. Awesome, now I can access my nc anywhere and use cheap disk space on my home server :slight_smile:

That’s the part from config.php that did it:

'overwrite.cli.url' => '',
'overwritehost' => '',
'overwriteprotocol' => 'https',
'overwritewebroot' => '/',
'overwritecondaddr' => '^192\\.168\\.23\\.1$',

I have a pretty fast internet connection, but even so, I’d like to access my server directly (without the round-trip to when I’m at home. I have no idea how to configure this. Can you help me there?

Thanks a lot!

this is known problem - often internet router (especially fritzbox) don’t allow the access to internal resources using public fqdn (rebound protection). Fritzbox offers a setting to disable this protection for certain dns names, but from my experience this doesn’t work for IPv6 (at least if you point you public DNS record as CNAME to you myfritz DNS record). The solution would be to setup internal DNS server like pihole and point you nextcloud domain to the internal IP address of the reverse proxy.

Thanks, I’ll try that!