Access forbidden - again

Hi all!
Well, topic states it, my Collabora won’t work :-/

Here’s my setup:

I followed instructions from https://nextcloud.com/collaboraonline/ and https://icewind.nl/entry/collabora-online/ - but when I try to open an ODT file within Nextcloud I get the ominous “Access forbidden” error.

Here’s my docker info:

Containers: 2
Running: 1
Paused: 0
Stopped: 1
Images: 1
Server Version: 1.13.1
Storage Driver: btrfs
Build Version: Btrfs v3.17
Library Version: 101
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: aa8187dbd3b7ad67d8e5e3a15115d3eef43a7ed1
runc version: 9df8b306d01f59d3a8029be411de015b7304dd8f
init version: 949e6fa
Kernel Version: 3.16.0-4-amd64
Operating System: Debian GNU/Linux 8 (jessie)
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 5.802 GiB
Name: cardhu
ID: CMCF:UYXK:HVEV:BJS3:QMFG:DNOR:N5VJ:CWT2:77MC:4MOC:DTTH:SYOQ
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No kernel memory limit support
WARNING: No oom kill disable support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

Docker logs for my Collabora container, that I fired up using
sudo docker run -t -d -p 9980:9980 -e "domain=cloud.domain.com" --restart always --cap-add MKNOD collabora/code

Generating RSA private key, 2048 bit long modulus
…+++
…+++
e is 65537 (0x10001)
Generating RSA private key, 2048 bit long modulus
…+++
…+++
e is 65537 (0x10001)
Signature ok
subject=/C=DE/ST=BW/L=Stuttgart/O=Dummy Authority/CN=localhost
Getting CA Private Key
loolforkit version details: 2.0.2 - 2.0.2

Now, when I try to access an ODT, I get that “Access forbidden” error, and the docker logs shows THIS:

wsd-00025-0027 20:53:22.066229 [ client_ws_0001 ] ERR Unknown resource: //hosting/discovery| wsd/LOOLWSD.cpp:1223

Any idea what might be the problem???

same issue here

Any solution found to this?

Found a few things (with the help of Ark74 from this forum):

  • The config linked on the nextcloud/collabora page differs from the official Collabora config. Have a look here: https://www.collaboraoffice.com/code/
  • inside NC you have to set the Collabora URL - but don’t add a trailing slash! It MUST be https://subdomain.domain.tld
  • Make sure your Webserver doesn’t set “X-Frame-Options SAMEORIGIN” - that’ll stop embedding of the office UI
  • According to some sources on the Web Chrome doesn’t honor X-Frame-Options, so i added a header ‘Content-Security-Policy “frame-src nextcloud.domain.tld collabora.domain.tld”’ to my nginx config. Chrome console complained about X-Frame-Options problems, though.

Nevertheless I still have troubles - “Well this is embarrassing. We cannot connect to your document” error…

According to this post there’s a big problem with using nginx as a webserver with Collabora 2.0 :-/

I have tried both the Collabora Config and the one on the NC tutorial with the same result.

I don’t have “X-Frame-Options SAMEORIGIN”.

Hmmmm… Does a rep from NC ever respond to these threads? There seem to be a lot of people with this issue that haven’t gotten it resolved.

Hi! I got email-notified you referenced my earlier post with Collabora. I forked the install script provided by husisusi for libreoffice online instead of CODE and now it works for me with nginx and without the 10 documents limitation. It’s available on my github here: https://github.com/methuselah-0/libreoffice-online-install.sh maybe it will work for you too. I also got audio/vidoe-conferencing working with spreedme and Im working on an install-script for that as well. Just letting you know =)

Can we get a “for dummies” tutorial on how to use the script from github? :slight_smile:

I added most install instructions in the README already. I can’t really assist more than that atm, sorry, but good luck with it.

That sounds great - I’ll give it a try when I’m back home and after a few days - I was away for three weeks, and my kids and my girlfriend need a little attention first :wink: