About the DDNS Let's Encrypt SSL


I installed Nextcloud for the first time. I have been using a DDNS which my Asus Modem is providing as a service. Let’s assume that my domain is myhomedomain.asuscomm.com

I had 2 Raspberry PIs connected to my modem both have static ips with forwaded ports for different uses. One is using octoprint and it as 4 printers connected to it.

I used to be able to connect to my printers by entering “myhomedomain.asuscomm. com:2500” port which was forwarded to the local static ip of that raspberry pi.

Oh by the way, I didn’t have any SSL for this connection. No Let’s Encrypt or any other service.

After installing Nextcloud there was a place where it’s asking for the domain to connect to Nextcloud to create an instance.

I wrote myhomedomain.asuscomm. com and after the installation was over, I could connect to Nextcloud with secure connection with the addrress myhomedomain.asuscomm. com with SSL enabled automatically. And I don’t even enter any port number for this. It just connects. Could this be because I wrote myhomedomain.asuscomm.com to that domain entry?

But after this, I’m not able to connect to my printers anymore through the domain with their ports. So myhomedomain.asuscomm.com:2500 doesn’t work anymore, instead I have to use the local static ip such as 192.168.xx.xx:2500 to connect to the printer.

What might have broken this? Should I have maybe entered to the domain for the instance when installing the Nextcloud as myhomedomain.asuscomm.com:443 (this time including the port) ?

How can I disable the SSL Let Encryps that Next Cloud created?

Thank you.


getting SSL “automaticly” means your http requests are redirected automaticly to the https of your nextcloud domain, “jumping over” your non-SSL printer ports.

Especialy if your config says every request for *.asuscomm.com goes to https://myhomedomain.asuscomm.com

I think a clean virtualhost config and or letsencypt with certbot for everybody can solve your problem.

check the way there here: