413 error the file is too large

I keep getting this error in my nextcloud ios app. I have searched and used the solution they use but to no avail. I have no problem with the desktop app.

My setup:
I have nextcloud running in a docker container in unraid. This is behind Cloudflare’s Argo tunnel.
unraid os: 6.11.5
nextcloud: 24.0.4
Database: MariaDB


The solution below so far I tried but still getting errors. I have always restarted the docker container every time I modified the configs.

  1. Modified default.conf in /appdata/nextcloud/nginx/site-confs/

  2. Modified nginx.conf in /appdata/nextcloud/nginx/

  3. Modified php-local.ini in /appdata/nextcloud/php/

  4. I also tried the chunk size but still getting error.

What could be wrong? Did I miss something? Please help me.

I’m on a very similar setup: Docker NC 25.0.1, cloudflared, with similar adds to config files (although I don’t believe that I have Nginx).

I have same error message on about 50 remaining upload mov files. I’ve seen info in the issues log on GitHub that the chunk size is supposed to alleviate this, but wasn’t working in iOS for a long while - with some signs pointing to it being fixed recently (idk for sure)!

I also tried changing the cloudflare page rules to bypass in cache level settings. This didn’t work either…if you find a solution, would appreciate an update!


I updated my iOS app just about 2 days ago with their new release and chunking started to work for me on my setup, hopefully it is resolved for you too!


The chunk file is working but it needs to run in foreground.

It worked for me after I cleared the cache in the app on my iPhone.