413 Error: Nextcloud iOS 100MB+


I get a ‘413’ error when auto uploading .mov items from my iOS device using the Nextcloud App
I’ve changed the .php, apache, etc… to allow files greater 1GB and I can’t seem to solve the issue.


Any tips or tricks?

Thank you

Hi !

Are you accessing your server with SSL?

If it is the case, you should also increase the SecRequestBodyLimit limit.

See: https://stackoverflow.com/a/14690797

My ModSecurity file is located here: /etc/modsecurity/modsecurity.conf

You can also see the Apache logs here to troubleshoot your problem: cat /var/log/apache2/error.log

Hello greggggg,

Thank you for the reply. I can’t seem to locate the /modsecurity.conf
My server is currently running Plesk Onyx Version 17.5.3 and the file location doesn’t seem to be standard.

I’ve been able to locate a few files in regards to Modsecurity but nothing in reference to SecRequestBodyLimit

Still running into issues of not being able to upload 100MB+ using the iOS Nextcloud App, I have no problems being able to upload larger files using the desktop client or web interface.

Same happens to me only in the IOS App (not tested on android). I get an 413 when im trying to upload a 6MB file. But it will be uploaded partially. I can upload ~1 MB then I get a 413 and later it trys again and gets 1 MB uploaded and so on till it finished. It does not happen on the desktop client.

Im using nextcloud with docker and a nginx reverse proxy

I know this is an old thread, but I just had to deal with this issue myself. I updated the machine I run my nginx reverse proxy on and for some reason ios uploads of any decent size failed with a 413 error also until I added a value for client_max_body_size in the server block that forwards to my Nextcloud instance. YMMV.

Hi all,

I had the same problem with the IOS app and I followed this topic:

The first time, it worked for me, but after a second install of Nextcloud with docker, it didn’t work anymore.

I noticed that the container my_custom_proxy_settings.conf file was not the same as the one I saved next to the docker-compose.yml file

Then I’ve modified the my_custom_proxy_settings.conf inside the container:

docker exec -it [container_ID] bash

It was empty (???)

After that, without restart, I could upload files with my iOS app.

Finally, this problem is resolved. I don’t understand how this issue fix the problem!!!

Why the config file did not update in the container?

Have you got an idea?