403 error when accessing /nextcloud/settings/users/users


I installed nextcloud on nginix using the example configuration script provided to install under a subfolder nextcloud on my webserver. I’ve noted that while the majority of the application seems to work, I get errors in my log file as follows:

- [26/Apr/2017:15:09:01 +0100] “POST /nextcloud/settings/users/users HTTP/2.0” 403 15858 “-” “Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0”

To get this error yourself, try and add a user, but provide a password that is inadequate - you should get a popup if I recall correctly from using this with apache, but you get no feedback, the “create” button just does nothing.

Presumably the configuration file for nginix is incorrect and I need to alter it to allow access to the users.php file, but I’ve tried a number of guesses based on the other entries in the file already and none have worked. Please can someone say the alteration that is required. Thanks.

Did you start with the default config from the documentation?

Yep :-(. I’ll start again with a fresh copy of that. Maybe I’ve an obscure typo somewhere. Thanks for the suggestion.