403 error and client denied by server configuration in apache, require all granted and allowoverride none set in config

Nextcloud version 17.0.1-1:
Operating system and version ARCH linux-lts 4.19.86-1-lts:
Apache or nginx version Apache 2.4.41:
PHP version 7.4.0-2:

The issue you are facing:

Is this the first time you’ve seen this error? Y:

I clean installed nextcloud on my arch server, I did copy the data from my snap nextcloud (on another server, trying to migrate) and put it in /var/nextcloud, but since the server won’t even initialize I don’t think that part matters. I set up a new certificate (openssl), managed to configure apache to use it, and set nextcloud to use my base domain (example.tld).

The access log says the following (shortened since there’s a lot of the same message from me trying continuously, all actual ipv4 addresses replaced with ):

<ipv4-address> - - [01/Dec/2019:18:54:13 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:16 +0000] "GET / HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:18 +0000] "GET / HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:18 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:23 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:28 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:33 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:33 +0000] "-" 408 -
<ipv4-address> - - [01/Dec/2019:18:54:38 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:43 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:48 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:53 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:54:58 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:03 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:08 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:13 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:18 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:23 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:28 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:33 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:38 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:43 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:48 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:53 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:55:58 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:56:03 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:56:08 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:56:13 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:56:18 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:56:23 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:56:28 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:56:33 +0000] "PROPFIND /remote.php/dav/files/gladtherescake/ HTTP/1.1" 403 1024
<ipv4-address> - - [01/Dec/2019:18:56:37 +0000] "GET /index.php/204 HTTP/1.1" 403 1010
<ipv4-address> - - [01/Dec/2019:18:56:38 +0000] "GET /index.php/204 HTTP/1.1" 403 1010

The dav files being requested by my phone trying to sync and obviously failing, which is expected. The requests for the root website coming from my browser where I get a 403.
The error log says the following (shortened as well as it’s all the same), prompting me to look for solutions for this with no avail:

[Sun Dec 01 19:09:13.490604 2019] [authz_core:error] [pid 15444:tid 139748437915392] [client <ipv4-address>:42810] AH01630: client denied by server configuration: /var/nextcloud/remote.php
[Sun Dec 01 19:09:18.473011 2019] [authz_core:error] [pid 15444:tid 139748429522688] [client <ipv4-address>:42810] AH01630: client denied by server configuration: /var/nextcloud/remote.php
[Sun Dec 01 19:09:21.484298 2019] [authz_core:error] [pid 15530:tid 139749598344960] [client <ipv4-address>:36295] AH01630: client denied by server configuration: /var/nextcloud/api
[Sun Dec 01 19:09:21.484665 2019] [negotiation:error] [pid 15530:tid 139749598344960] [client <ipv4-address>:36295] AH00690: no acceptable variant: /usr/share/httpd/error/HTTP_FORBIDDEN.html.var
[Sun Dec 01 19:09:21.596919 2019] [authz_core:error] [pid 15530:tid 139749631915776] [client <ipv4-address>:36295] AH01630: client denied by server configuration: /var/nextcloud/api
[Sun Dec 01 19:09:21.597283 2019] [negotiation:error] [pid 15530:tid 139749631915776] [client <ipv4-address>:36295] AH00690: no acceptable variant: /usr/share/httpd/error/HTTP_FORBIDDEN.html.var
[Sun Dec 01 19:09:21.708152 2019] [authz_core:error] [pid 15530:tid 139749461300992] [client <ipv4-address>:36295] AH01630: client denied by server configuration: /var/nextcloud/api
[Sun Dec 01 19:09:21.708533 2019] [negotiation:error] [pid 15530:tid 139749461300992] [client <ipv4-address>:36295] AH00690: no acceptable variant: /usr/share/httpd/error/HTTP_FORBIDDEN.html.var
[Sun Dec 01 19:09:21.818992 2019] [authz_core:error] [pid 15530:tid 139749469693696] [client <ipv4-address>:36295] AH01630: client denied by server configuration: /var/nextcloud/api
[Sun Dec 01 19:09:21.819385 2019] [negotiation:error] [pid 15530:tid 139749469693696] [client <ipv4-address>:36295] AH00690: no acceptable variant: /usr/share/httpd/error/HTTP_FORBIDDEN.html.var
[Sun Dec 01 19:09:21.933576 2019] [authz_core:error] [pid 15530:tid 139749478086400] [client <ipv4-address>:36295] AH01630: client denied by server configuration: /var/nextcloud/api
[Sun Dec 01 19:09:21.933936 2019] [negotiation:error] [pid 15530:tid 139749478086400] [client <ipv4-address>:36295] AH00690: no acceptable variant: /usr/share/httpd/error/HTTP_FORBIDDEN.html.var
[Sun Dec 01 19:09:22.045573 2019] [authz_core:error] [pid 15530:tid 139749606737664] [client <ipv4-address>:36295] AH01630: client denied by server configuration: /var/nextcloud/.well-known
[Sun Dec 01 19:09:22.045878 2019] [negotiation:error] [pid 15530:tid 139749606737664] [client <ipv4-address>:36295] AH00690: no acceptable variant: /usr/share/httpd/error/HTTP_FORBIDDEN.html.var
[Sun Dec 01 19:09:22.158322 2019] [authz_core:error] [pid 15530:tid 139749615130368] [client <ipv4-address>:36295] AH01630: client denied by server configuration: /var/nextcloud/api
[Sun Dec 01 19:09:22.158686 2019] [negotiation:error] [pid 15530:tid 139749615130368] [client <ipv4-address>:36295] AH00690: no acceptable variant: /usr/share/httpd/error/HTTP_FORBIDDEN.html.var
[Sun Dec 01 19:09:23.474381 2019] [authz_core:error] [pid 15444:tid 139748421129984] [client <ipv4-address>:42810] AH01630: client denied by server configuration: /var/nextcloud/remote.php

I have already tried changing the virtualhost config for my nextcloud installation to have AllowOverride None and Require all granted set, it doesn’t have any effect on the situation, even when put in the global config.

<IfModule mod_alias.c>
    Alias /nextcloud /usr/share/webapps/nextcloud/
</IfModule>

<VirtualHost *:80>
    ServerAdmin webmaster@gladtherescake.eu
    DocumentRoot /usr/share/webapps/nextcloud
    ServerName gladtherescake.eu
    ErrorLog /var/log/httpd/gladtherescake.eu-error_log
    CustomLog /var/log/httpd/gladtherescake.eu-access_log common
    <Directory /usr/share/webapps/nextcloud/>
        AllowOverride None
        Options +FollowSymlinks
        Options -Indexes
        Require all granted
        Satisfy Any
    </Directory>

</VirtualHost>

I’m honestly at a loss, I can’t find any other configuration online that might affect this, and permissions are also correct, I even tried to set my folders (data in /var/nextcloud, and the application in /usr/share/webapps/nextcloud) to 777, and setting the user and group to http (my apache user) to no avail either. If anyone has any recommendations to what logs to look at, or what configuration to try I’d be really grateful for the help. Thanks in advance.