401 with iOS app


I have a problem with the iOS app and nextcloud 11.0.1 .

I’ve enabled the app “Two Factor TOTP Provider” (1.1.0), and now I’ve a 401 error while trying to use the iOS app. I’ve try to use a generated application password as well as my standard password, neither of them work. The authentification works on the standard web UI with 2FA.

When I disable the 2FA, my standard password works using the iOS app.

Here’s my configuration :
Ubuntu 16.04.2
postgresql 9.5
https enabled using letsencrypt

Any ideas ?

Thank you for your help :slight_smile:

Ok I’ve a workaround :

I try to generate an application password before enabling the 2FA.
Then I connect to the iOS app using this password; it works, obviously :slight_smile:

Then I enable the 2FA; and I’m able to connect to the iOS app :slight_smile:

Hi @gtrdblt please write for all users the correct procedure for using TOTP with mobile device :slight_smile: Thanks.

Yes :slight_smile:

Here it is :

  • Connect yourself to the iOS app, using your user password
  • Enable 2FA

If you’ve already enabled 2FA, juste disable it, then connect to the iOS app using your user password, and then re-enable 2FA :slight_smile:

Quite simple, but not that secure :frowning: