401 login error from android app

Nextcloud version : 13.0.4
Operating system and version : CloudLinux Server release 6.9
Apache or nginx version : Apache 2.4
PHP version : 7.0

The issue you are facing:

http 401 error on login from Android devices. iOS doesn’t show the error but also won’t authenticate. Login to web from a browser works fine.

Is this the first time you’ve seen this error? : Y

This installation has worked for months before the issue occurred.

Steps to replicate it:

  1. Install the Android app
  2. Log in
  3. Feel dejected

The output of your Nextcloud log in Admin > Logging:
{“reqId”:“W1FR-@PzTih@LXq6gc2n8AAAAMY”,“level”:2,“time”:“2018-07-20T03:07:44+00:00”,“remoteAddr”:“my.ip.add.ress”,“user”:"–",“app”:“core”,“method”:“POST”,“url”:"/index.php/login?redirect_url=/index.php/login/flow/redirect%3FstateToken%3Dj1ai3wjngdr3zKT5hW4P2Ezob9dHCSGrFNPMHHngqCQdE9x3Uc5BgvfkgPm5Y4Z0%26clientIdentifier%3D",“message”:“Login failed: ‘larry’ (Remote IP: ‘my.ip.addre.ss’)”,“userAgent”:“Google Pixel 2 XL”,“version”:“”}
{“reqId”:“W1FSHFZQOjc-pBMqDnneQgAAAJM”,“level”:2,“time”:“2018-07-20T03:08:12+00:00”,“remoteAddr”:“”,“user”:"–",“app”:“core”,“method”:“POST”,“url”:"/index.php/login?user=larry&redirect_url=/index.php/login/flow/redirect%3FstateToken%3Dj1ai3wjngdr3zKT5hW4P2Ezob9dHCSGrFNPMHHngqCQdE9x3Uc5BgvfkgPm5Y4Z0%26clientIdentifier%3D",“message”:“Login failed: ‘larry’ (Remote IP: ‘my.ip.addre.ss’)”,“userAgent”:“Google Pixel 2 XL”,“version”:“”}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php $CONFIG = array ( 'debug' => true, 'instanceid' => 'xxxxxxxxxxxxxxxxxxxx', 'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxx', 'secret' => 'xxx', 'trusted_domains' => array ( 0 => 'nextcloud2.domain.org', ), 'datadirectory' => '/home/domain/nextcloud2data', 'overwrite.cli.url' => 'http://nextcloud2.domain.org', 'dbtype' => 'mysql', 'version' => '', 'dbname' => 'domain_largo', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'dbuser' => 'domain_largo', 'dbpassword' => 'greatpassword', 'installed' => true, ); The output of your Apache/nginx/system log in `/var/log/____`: error_log: nothing from my IP access_log: my.own.ip.addy - - [19/Jul/2018:21:45:06 -0500] "GET /ocs/v2.php/apps/notifications/api/v2/notifications HTTP/1.1" 200 926 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36"

The site owner also points out that other methods to connect also fail - Thunderbird calendar plugin, linux app, pretty much everything but the web interface.

Any thoughts? Any place I can begin looking?

Things we have tried:

  • installing a 2nd instance of NextCloud from scratch - same result
  • installing on another domain on the same server from Softaculous - no joy
  • temporarily disabling the firewall - no difference