28.0.0. beta 3 installation issue

I’m on the beta testing update path and am getting:

Composer autoloader not found, unable to continue. Check the folder “3rdparty”. Running “git submodule update --init” will initialize the git submodule that handles the subfolder “3rdparty”.

How did you update ?

Through the web interface in my nextcloud instance. It gave an error telling me to delete a step file from a particular folder and to try again which I did and the error in my OP was the result.

I see. There was an issue with the Beta2 updater, maybe check that out? Third beta of Nextcloud 28

I followed the steps and then tried the web updater again and got this:


and after a while I press the Retry update button and get this:

So then I wait and nothing changes so I delete the step file again which leads me back to the error in the OP and now I can’t use nextcloud

What @SysKeeper is saying

Mh, and at that state try to move away the .step file from /path/to/nextcloud/data/updater-$INSTANCEID/.step and retry.

I tried to follow those steps but that file did not seem to exist.

Now I am getting “Update in process”.

I have tried deleting the updater.phar and index.php as per the beta 3 thread and downloaded the latest beta 4 copies then tried to run the phar file again but the installation fails from the CLI saying it can’t find files in /updater/updater.phar/lib/…etc but I cannot see any other files in the /updater folder apart from index.php and updater.phar

The file does exists, you need to check in your nextcloud data dir, replace the instance id in “updater-$INSTANCEID” and mind that .step is a hidden file.