- Parsing response failed

Similar to Update Fails: 19.0.6 -> 20.0.3 (Verifying Integrity) but the process is always interrupted at step 6

My current Nextcloud vesion is and the updater.log only has:

2023-06-22T12:25:10-0500 U0eyrl4ryJ [info] request to updater
2023-06-22T12:25:10-0500 U0eyrl4ryJ [info] currentStep()
2023-06-22T12:25:10-0500 U0eyrl4ryJ [info] Step 6 is in state "start".

I have deleted the .step file to try to re run the updater and it always get stucked at step 6.

Hmm, here are previous topics on this step with instructions for ways to address:


The Parsing response failed is somewhat of a generic error message.

We need the lines prior to the Step 6 is in a state "start" from your updater.log. Those three lines just indicate it’s waiting for that step, but the useful stuff would get logged before that. Are you saying there are no other log entries?

What’s are the basics of your NC environment? You didn’t fill out the support form so no idea what to suggest otherwise just yet.

Are you running the updater from the web interface or the command-line?

If you’re doing it from the web, may want to give the command-line a try:


No prior lines, the log had only what I showed.

And, by curious I ran the updater.phar and it worked, so, maybe some didn’t worked via web but I wasn’t able to find the issue, and neither I found some solution in the link that @just posted.