22.2.3 - `imagick` Error Message

Hello,

I am receiving this error: * This instance is missing some recommended PHP modules. For improved performance and better compatibility it is highly recommended to install them.
imagick

I am receive this error and despite running all commands I could find to correct this error message is will not go away.

Any help is greatly appreciated.

Thank you,
Jason

Have you install php module for imagick?

apt install php-imagick

Yes, but I just ran the command again and here is the response:

php-imagick is already the newest version (3.4.4-4).

Still the error on my Nextcloud webpage under settings>overview remains.

All the help is much appreciated,
Jason

I ran the remove command and then installed again and same issue. Server is station under overview that imagick is not installed.

What is the issue here?

Any help is greatly appreciated.

Thank you,
Jason

If Nextcloud is running in a Docker container, install php-imagick inside the container.

NC was installed via SNAP.

What is the procedure?

Much appreciated,
Jason

This is an old post, but I understand that is not posible to change/update manually your php-imagick because it is build inside the snap package…

It seems that the SNAP mainteners don´t like the imagick package because of security terms, so it isn´t in the package and that´s why you are getting the warning. This is what they recomend:

The warning will go away if you disable the theming app. If you need the theming app, then you don’t get automatically-generated favicons. I think that’s the only feature imagick gives you (but I could be wrong-- I have it disabled).

Hope this can help with your problem.