2.5 not connecting to my server, 2.3.x works

Hi all.

Upgraded to the 2.5 version of the Desktop client but I can no longer connect to my server. This is on a machine that has worked for 6+ months. Its a windows machine.

I tried 2.5 on a Mac in a different office entirely and it doesn’t work either. It lets me login, finds the server and is happy to even list the directories I may want to sync but once the wizard is finished it just tells me there is no connection to the server and the tray icon remains greyed out.

If I install 2.3.x client back on those machines they work happily as they did before. The only change I have made to my knowledge is trying the new clients. My server sits behind Cloudflare but that can’t be an uncommon scenario but worth a mention just in case.

I just updated to the new client and also began not being able to connect to my local server. The previous client had been working for me. I saw where someone else tried connecting using an outside address rather than a local network address. That worked for me.

Don’t use:
Do use: https://my.publicdomain.com/nextcloud

Hope this helps

I just installed 2.5 on a Linux Mint 19 machine and, after prompting me to log in again, says “No connection to Nextcloud at [my hosted URL].” The 2.3 client worked flawlessly. Now there is no Activity showing, no synchronizing, nothing. 2.5 will list my apps to choose from in the client systray menu, so it’s obviously hitting my server, but it’s not showing any action in the settings display. Storage space also reads as …

Any ideas besides downgrading to 2.3?

Have the same problem here. Interestingly the 2.5.x client connects to a NC15 instance, but would not connect to a NC14. After I deactivated the E2E app in NC14, the desktop client would request the login credentials again and start syncing. (Ubuntu 18.10, client installed via PPA)
So the current problem is that the E2E app cannot be reactivated (only if i want to lose desktop sync)