15mb core-common.js ?!

Still not sure why group folders needs 4mb of scripts but I’ll take that since I choose to use it. core-common.js is quite ridiculous though.

I had a quick scan inside and it seems at least 20% if localization with over 1mb for just images for countries. Any way to reduce the size? In V28, a breakdown of the file is on the milestone, but it will still have 15mb of data, just in chunks. We have a few remote areas and with the spotty connection, they cannot fully load the page before it fails sometimes. Some older devices do not cache such large files either

Currently on V27.1.0 Beta3, noticed this since V26 but maybe was in earlier versions as well. I have disabled and removed most of the apps. Do I need to rebuild core-common.js?

Apps

Enabled:

  • activity: 2.19.0
  • admin_audit: 1.17.0
  • bruteforcesettings: 2.7.0
  • cloud_federation_api: 1.10.0
  • comments: 1.17.0
  • dav: 1.27.0
  • external: 5.2.0
  • extract: 1.3.6
  • federatedfilesharing: 1.17.0
  • files: 1.22.0
  • files_accesscontrol: 1.17.0
  • files_downloadactivity: 1.16.0
  • files_external: 1.19.0
  • files_pdfviewer: 2.8.0
  • files_rightclick: 1.6.0
  • files_sharing: 1.19.0
  • files_trackdownloads: 1.11.0
  • files_trashbin: 1.17.0
  • files_versions: 1.20.0
  • files_zip: 1.4.0
  • groupfolders: 15.0.2
  • lookup_server_connector: 1.15.0
  • metadata: 0.19.0
  • oauth2: 1.15.1
  • onlyoffice: 8.2.0
  • password_policy: 1.17.0
  • previewgenerator: 5.3.0
  • privacy: 1.11.0
  • provisioning_api: 1.17.0
  • related_resources: 1.2.0
  • settings: 1.9.0
  • systemtags: 1.17.0
  • theming: 2.2.0
  • theming_customcss: 1.14.0
  • twofactor_backupcodes: 1.16.0
  • updatenotification: 1.17.0
  • viewer: 2.1.0
  • workflowengine: 2.9.0

Disabled:

  • circles: 27.0.1 (installed 25.0.0)
  • contactsinteraction: 1.8.0 (installed 1.8.0)
  • dashboard: 7.7.0 (installed 7.6.0)
  • encryption: 2.15.0
  • federation: 1.17.0 (installed 1.9.0)
  • files_reminders: 1.0.0 (installed 1.0.0)
  • firstrunwizard: 2.16.0 (installed 2.15.0)
  • logreader: 2.12.0 (installed 2.12.0)
  • nextcloud_announcements: 1.16.0 (installed 1.8.0)
  • notifications: 2.15.0 (installed 2.15.0)
  • photos: 2.3.0 (installed 1.1.0)
  • recommendations: 1.6.0 (installed 0.7.0)
  • serverinfo: 1.17.0 (installed 1.17.0)
  • sharebymail: 1.17.0 (installed 1.17.0)
  • support: 1.10.0 (installed 1.2.1)
  • survey_client: 1.15.0 (installed 1.7.0)
  • suspicious_login: 5.0.0
  • text: 3.8.0 (installed 3.8.0)
  • twofactor_totp: 9.0.0
  • user_ldap: 1.17.0 (installed 1.17.0)
  • user_status: 1.7.0 (installed 1.6.0)
  • weather_status: 1.7.0 (installed 1.6.0)
1 Like

Hi, one current workaround for it is this: https://github.com/nextcloud/documentation/blob/5dde59862fe9a60b2bceb534e5095e201cec8a43/admin_manual/installation/server_tuning.rst#compression which is btw automatically configured when using Nextcloud AIO.

Great. But unfortunately this does not help on Android WebView. There the 15MB get downloaded each single time I open a document in Files app and each first time when opening a note in the Notes app. I already created issues on the corresponding repositories (Files and notes-andorid).
Any workaround for those?

Nextcloud docs with Collabera? Or Only office?

I notice that too with only office. I enabled Brotli, HTTP3 and QUIC. Compression brings them down to 4mb transferred from nearly 20mb.

But this wouldn’t be a nextcloud problem. Im investigating if turning off features in only office if it reduces the size but it seems no change so far

We are using Text & Collabora. You can track the used amount of data in Android settings. Check before opening a document and then after openig a document. It’s round about 16MB, but I’m sure the most of that can be cached. However, mobile data is expensive and opening a few documents increase the used data a lot.
I already found something in the code but never came around to build & test myself. See the corresponding issue on files app.

I assume you’re using Android chrome?

Download ADB on your computer and connect to your phone (first have to connect USB)

Then in your chrome browser on the desktop, you can connect to a debug session where you can use the network tab to see which files are cached.

If every request is downloaded like what it seems you show, then it might be cache headers setting on your server. It can only cache what its told to cache by the server

I’m using Android System WebView v115.0.5790.136, so yes, based on chronium. I also tried switching to Google Chrome’s WebView but with the same effect, so switched back to system default. As default browser I use Firefox (Android & Desktop) but that shouldn’t matter for the used WebView implementation.

Good to know, I’ll install Chrome on Desktop and try that out the next days. Thanks for the hint! :slight_smile:

Any hint what I need to check on my server configuration (Apache, PHP) for that configuration or what recommendation I can follow? Didn’t find a clear answer via quick googeling (may investigate more time the next days). ;D
As alternative I would try to adjust my configuration for the nextcloud vhost more to AIO docker.

If it’s a server config issue, headers should be the same on your computer. So you can have a look at cache headers which should be
Response header “cache-control”

Well, then I’m back to my issue below becauase it’s only on mobile. I’m going to check that via ADB the next days, let’s see what I’ll find out. Will post my results at the post below.

It’s also an issue on the client-side:

image

1 Like