15.0.2 PHP version

Of what I can deduce from that message I get from the “Overview” page is that Ubuntu 16.04 does not support the most recent PHP version.

I tried “apt update” than “apt upgrade” and it upgraded a bunch of stuff but PHP is still not at the most recent.

Is it safe/recommended to do a distro-upgrade?

Thank you

you can install only php new version (ae 7.2)
apt install php7.2 libapache2-mod-php7.2 php7.2-cli php7.2-common php7.2-curl php7.2-gd php7.2-intl php7.2-json php7.2-mbstring php7.2-mysql php7.2-opcache php7.2-readline php7.2-xml php7.2-zip

for apache2 use:
a2dismod php7.0
a2enmod php7.2
systemctl restart apache2

you should know what you are doing, it is only one way

1 Like

Thanks for the reply. I know how to copy paste commands but if something breaks I’m screwed.

So, I will not do it for now unless someone says it is totally safe.

the first part is safe (as it could be), you have only a second softwarepackage at your System
What Webserver is yours? Apache2?

Well, I think nobody can guarantee that it is “totally safe”. Never change a running system… :wink:
I had a lot of trouble with dist-upgrades and Ubuntu in the past that ended up with a fresh installation.
If you work in a virtual environment then you could test “risk free” wtih a snapshot of the actual state.
Or you could image/clone the system if is a physical one.

Good luck & best wishes

Yes, Apache2

As blu-IT wrote, a dist-upgrade is much more risky, only install php7.2, is safer.

The second step you can easy go back.

1 Like

Why not give the docker container a try? You would never again have issues like this. You can even try to make the move with your existing box (after disabling whatever web server you currently have on, whether be apache or nginx).

Let me know if you would like any help with that.

Very interesting, could you tell us in more detail?

You can install PHP 7.2 / 7.3 following this guide:

1 Like

Not sure how familiar you guys are with docker, but it is basically an operating system virtualization engine, not to be confused with full virtualization though. Think of it as more like sand-boxing. You install containers, which have all the software they need to run whatever task they have. This allows you to run full stacks of containers that will run exactly the same no matter what OS you have.

For example, in @tiripon’s case, he can be running the latest Nextcloud 15.0.2 with an alpine or debian OS in its container, but his host OS will remain Ubuntu 16.04. When and if he decided to upgrade his host server, he simply moves all the docker persisted files and container definitions, and boom, the exact same Nextcloud will be running in minutes. I know I am putting it in too simple terms but that is exactly what it does.

In terms of resource utilization, the overhead is very negligible.


After the 15.0.2 update (from version 15.0.0), overwrite.cli.url no longer evaluates. I run a server on xxx.de and externally I speak it on yyy.de. But only every URL is converted to xxx.de / … Until version 15.0.0 the URL was always yyy.de / …

How can I restore the previous behavior?


Thank you @eehmke. I folowed the instructions and now my php version is at 7.2.14-1. It says so when I type php -v in putty.

But there is still a problem:
I completely re-booted the server and when I go the Overview page it still says: “You are currently running PHP 7.0.32-0ubuntu0.16.04.1.”

Nextcloud can’t detect the new version?

1 Like

@tiripon: it’s not nextcloud, it’s apache: you need to configure your virtual server to use the right version of php; and possibly apply any custom configuration you have in your php7.0 php.ini over to the new php.ini

@Traceman : make sure your overwrite.cli.url ends with a slash, I found there were issues with the occ CLI - htaccess command unless it had it - I know it’s not related but it could be a part of your issue

I don’t know why I received this, but I am running Mac OS 10.14.2 with PHP 7.2.12 and NextCloud 14. I do plan to upgrade to 7.3.x, soon. I also have this on Linux Mint 19, but that machine will be shutdown soon.

Thanks @riczorn

This is getting too complicated. I was expecting the upgrade to go smoothly. I don’t understand why it causes so much problems (I did not even start to troubleshoot the second message I got about “Missing index”)
A little bit disappointing.
I will put back my backup and leave it on version 14.

I just installed Ubuntu 18.04 LTS and am happy with the results.

Fred Lloyd, AA7BQ
President and Founder, QRZ


I’m running Raspian Stretch, PHP 7.0 is max. Buster gets 7.3, but a
Buster Raspian image is more trouble than I care to indulge in. I did it
and ended up in a total rebuild back to Stretch.

Until Debian Buster (10) goes stable this is my rev. Freeze is scheduled
for 3/12/19, so it will be as while yet.

If anyone wants to discuss migration to docker, and would like support you can use my livechat at:


Obviously, because I have a development job, I do not promise to be 100% available, but most of the time I am.

Has NC updated its documentation? 7.0 was the only version that officially associated with NC. While 7.2 was possible with odd workarounds. It would be great to know the official position now. These kinds of issue raise the question as to whether NC is “a safe place for all of your data”