_spreed.me_ will nicht so, wie ich das mag

Hej zusammen,

Nextcloud soll ja spreed.me unterstĂŒtzen, wenn ich das richtig verstenden habe. Jetzt wollte ich mir das mal etwas nĂ€her ansehen und komme schlicht nicht weiter. Vielleicht kann mir hier ja wer weiterhelfen.

Ich bin hier hin, um mir die App zu besorgen. Habe sie entpackt und unter 3rdparty hochgeladen. Habe im Anschluß daran aber noch nichts unter Apps in der Nc gefunden gehabt. Nun steht ja auf der gleichen Seite, dass diese App nur funktioniert, wenn WebRTC auf dem Server lĂ€uft.

Bin ich als hier hin. Habe mir den Code heruntergeladen:

sudo wget https://github.com/strukturag/spreed-webrtc/archive/master.zip

Dann habe ich das entpackt:

sudo unzip master.zip

Dann habe ich versucht im neuen Directory spreed-webrtc-master/ autogen.sh auszufĂŒhren:

./autogen.sh

Und das war das Ergebnis:

pi@nextcloud:~/spreed-webrtc-master $ ./autogen.sh
ln: failed to create symbolic link Ăą.git/hooks/pre-commitĂą: No such file or directory
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4
autom4te: cannot create autom4te.cache: No such file or directory
aclocal: error: echo failed with exit status: 1
autoreconf: aclocal failed with exit status: 1
pi@nextcloud:~/spreed-webrtc-master $

Ich glaube, dass ich die AbhĂ€ngigkeiten Go, NodeJS, autoconf & automake korrekt installiert habe, aber sicher bin ich da nicht. Die Dokus sind stellenweise fĂŒr mich nicht eindeutig genug.

Kennt sich damit vielleicht von hier wer aus und wÀre bereit, mir damit zu helfen, dass zum Laufen zu bringen?

Viele GrĂŒĂŸe
//nephilim

Discussion transferred to GH: https://github.com/strukturag/spreed-webrtc/issues/300

Hallo,
habe gerade das gleiche Problem, nur dass der WebRTC-Server bereits lĂ€uft. Der Spreed.me-Button fehlt und die App lĂ€sst sich auch nicht aktivieren. Hast du dafĂŒr eine Lösung gefunden?

Edit: Habe jetzt die experimentellen Apps mit

‘appstore.experimental.enabled’ => true

aktiviert, jetzt bin ich wenigstens einen Schritt weiter.

Ich habe nicht einmal den Server ans Laufen bekommen. Stelle mich da wohl zu blöd an. Vielleicht kannst Du mir ja helfen dabei? :wink:

LG // nephilim

Hast du git installiert?

Nein. Geht es auch ohne?
Von unterwegs


Ich bin mir nicht sicher, kann mich auch irren. Ich muss es wohl nochmal auf einer neuen Maschine compilieren.

Hi nephilim,

hast Du das Problem schon gefunden / behoben bzw. bist Du einen Schritt weiter?
ErhÀltst Du immer noch den Fehler autom4te: cannot create autom4te.cache: No such file or directory nach einem ./autogen.sh?

Hej Leon,

ich hatte das Script nicht als “root” ausgefĂŒhrt. Als ich das als “root”-User tat, kam ich einen Schritt weiter. Jetzt scheitere ich an der “go”-Installation.

LG // neph

Hi nephilim,

Du kannst Go per apt-get install golang installieren.
From-source installieren geht so: https://golang.org/doc/install/source

Hej Leon,

danke, bin wieder einen Schritt weiter dadurch. Jetzt hapert es daran, dass das ./configure script nicht durchlÀuft, weil Go in version 1.3.3 installiert ist, aber 1.4.0 benötigt wird.

Habe dann 1.3.3 wieder entfernt, weil hier steht, dass bei einem Upgrade die alte Version zuerst deinstalliert werden muss.

Habe dann Go v. 1.7 in /usr/local/go entpackt und das File /etc/profile sieht jetzt so aus:

# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).

if [ "`id -u`" -eq 0 ]; then
  PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
else
  PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games"
fi
export PATH=$PATH:/usr/local/go/bin

if [ "$PS1" ]; then
  if [ "$BASH" ] && [ "$BASH" != "/bin/sh" ]; then
    # The file bash.bashrc already sets the default PS1.
    # PS1='\h:\w\$ '
    if [ -f /etc/bash.bashrc ]; then
      . /etc/bash.bashrc
    fi
  else
    if [ "`id -u`" -eq 0 ]; then
      PS1='# '
    else
      PS1='$ '
    fi
  fi
fi

if [ -d /etc/profile.d ]; then
  for i in /etc/profile.d/*.sh; do
    if [ -r $i ]; then
      . $i
    fi
  done
  unset i
fi

Wenn ich nun ./configure laufen lasse, sagt er mir wieder, dass Go nicht installiert sei:

root@nextcloud:/home/pi/spreed-webrtc-master# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for grep that handles long lines and -e... /bin/grep
checking for a sed that does not truncate output... /bin/sed
checking for gawk... (cached) mawk
checking for find... /usr/bin/find
checking for gpm... no
checking for jshint... no
checking for python2... /usr/bin/python2
checking for version of python2... 2.7.9
checking for go... no
configure: error: Please install Go before trying to build spreed-webrtc.

Ist aus dem irgendwie zu erkennen, was ich bei der Go-Installation falsch mache?

Liebe GrĂŒĂŸe
//neph

Wo liegt die go binary?
Was ist der output dieses commands:

/usr/local/go/bin/go version

Hej Leon,

er sagt: no such file or directory. Aber ich sehe das folgende in /usr/local:

root@nextcloud:/usr/local# ls -alF
total 44
drwxrwsr-x 11 root staff 4096 Aug 31 17:59 ./
drwxr-xr-x 11 root root  4096 May 27 11:34 ../
drwxrwsr-x  2 root staff 4096 May 27 11:04 bin/
drwxrwsr-x  2 root staff 4096 May 27 11:04 etc/
drwxrwsr-x  2 root staff 4096 May 27 11:04 games/
drwxr-xr-x  8 root root  4096 Aug 15 22:48 go/
drwxrwsr-x  2 root staff 4096 May 27 11:04 include/
drwxrwsr-x  6 root staff 4096 May 27 11:40 lib/
lrwxrwxrwx  1 root staff    9 May 27 11:04 man -> share/man/
drwxrwsr-x  2 root staff 4096 May 27 11:04 sbin/
drwxrwsr-x  8 root staff 4096 May 27 11:19 share/
drwxrwsr-x  2 root staff 4096 May 27 11:04 src/
root@nextcloud:/usr/local#

Im go-Verzeichnis siehts dann so aus:

root@nextcloud:/usr/local# cd go
root@nextcloud:/usr/local/go# ls -alF
total 140
drwxr-xr-x  8 root root   4096 Aug 15 22:48 ./
drwxrwsr-x 11 root staff  4096 Aug 31 17:59 ../
drwxr-xr-x  2 root root   4096 Aug 15 22:47 api/
-rw-r--r--  1 root root  29041 Aug 15 22:47 AUTHORS
-rw-r--r--  1 root root   1168 Aug 15 22:47 CONTRIBUTING.md
-rw-r--r--  1 root root  40192 Aug 15 22:47 CONTRIBUTORS
drwxr-xr-x  8 root root   4096 Aug 15 22:47 doc/
-rw-r--r--  1 root root   1150 Aug 15 22:47 favicon.ico
drwxr-xr-x  3 root root   4096 Aug 15 22:47 lib/
-rw-r--r--  1 root root   1479 Aug 15 22:47 LICENSE
drwxr-xr-x 13 root root   4096 Aug 15 22:47 misc/
-rw-r--r--  1 root root   1303 Aug 15 22:47 PATENTS
-rw-r--r--  1 root root   1638 Aug 15 22:47 README.md
-rw-r--r--  1 root root     26 Aug 15 22:47 robots.txt
drwxr-xr-x 45 root root   4096 Aug 15 22:48 src/
drwxr-xr-x 18 root root  12288 Aug 15 22:48 test/
-rw-r--r--  1 root root      5 Aug 15 22:48 VERSION
root@nextcloud:/usr/local/go#

Ich habe hiermit die Variable angegeben: nano ~/.profile und dort ans Ende die folgenden Pfadangabe gesetzt: export PATH=$PATH:/usr/local/go/bin. Die Datei sieht dann so bei mir aus:

# ~/.profile: executed by Bourne-compatible login shells.

if [ "$BASH" ]; then
  if [ -f ~/.bashrc ]; then
    . ~/.bashrc
  fi
fi

mesg n
export PATH=$PATH:/usr/local/go/bin

Er erkennt nicht, dass Go installiert ist, aber ich weiß nicht, warum das so ist. Was habe ich ĂŒbersehen?

LG // neph

Go ist bei Dir nicht installiert :wink:

Wie bereits auf Github gesagt wurde, hast Du Dir (nur) die Go-Source 'runtergeladen.
Du brauchst aber eine ausfĂŒhrbare Go-Binary. Entweder Du compilest Dir das mit Hilfe der Source selbst, oder Du suchst + installierst ein vor-kompiliertes Go fĂŒr Deine Distribution.

Bitte folge der Anleitung auf https://golang.org/doc/install/source oder suche Dir ein Repository, wo das ganze schon gemacht wurde.

Ich verstehe bei der Installation nur Bahnhof. :frowning: Ich kann nicht compilen und die Begriffe dort kenne ich auch nicht und wo ich diese Variablen einsetzen muss, erkenne ich da auch nicht. Ich kenne mich mit Go nicht aus und kann es nicht einmal lernen, weil ich es nicht installiert bekomme. Frustrierend.

Trotzdem ganz herzlichen Dank an Dich, leon.

Viele GrĂŒĂŸe
//neph

Hallo zusammen,

ich habe Go installiert bekommen, genauer gesagt Go 1.5.

pi@nextcloud:~ $ go version
go version go1.5 linux/arm

Es ist in $HOME/go installiert, was bei mir bedeutet: /home/pi/go. Das ./configure-Script wirft aber wieder den Fehler aus, dass zunÀchst Go installiert werden soll:

configure: error: Please install Go before trying to build spreed-webrtc.

Ich vermute, dass das Script den Ort der Installation nicht ĂŒberprĂŒfen kann. Aber ich habe folgende Angaben gesetzt:

1x in /etc/profile. Dort habe ich die folgenden Variablen in die Datei geschrieben:

export GOROOT=$HOME/go
export PATH=$PATH:$GOROOT/bin

und dann das Selbe nochmal in $HOME/.profile (/home/pi/.profile).

Was könnte jetzt hier der Fehler sein und wie bekomme ich den weg?

Liebe GrĂŒĂŸe
//neph

Issue was “fixed” by symlinking the Go binary to /usr/local/bin.

@nephilim please do not create tasks for the same issue in this forum and on Github :slight_smile:

OK. I understand.

Thank you for all your assistance and patience.

Kind regards
//nephilim
Von unterwegs