Your web server is not properly set up to resolve "/ocm-provider/"

nc15
#82

The address I use to access my Nextcloud is https://xxxx.synology.me:XXXX/nextcloud/) where XXXX is the port I use which is then redirected to my NAS. The xxxx.synology.me part is a ddns service which points to my current external IP address.

1 Like

#83

I’ve got the same problem on my Synology. Nothing seems to work, like Redirect or Rewrite commands in the root .htaccess or nextcloud .htaccess.

0 Likes

#84

Interestingly I installed the Docker version of Nextcloud 15.0.5 on my Synology NAS and these error messages were not there. The only problem was that no matter what I did I couldn’t access the Docker version from outside my network - so back to the normal Nextcloud install and I’ll just pretend those error messages aren’t there.

0 Likes

#85

Thanks a lot! It works for me

1 Like

#86

Hi everyone, I use nextcloud on a shared hosting
PHP version: 7.2.3
Apache 2

I tried to add the following rules to my .htaccess file:
Redirect 301 /ocm-provider/ /nextcloud_folder/ocm-provider/
Redirect 301 /ocs-provider/ /nextcloud_folder/ocs-provider/

but the booty does not disappear …
why ? thank you so much

0 Likes

#87

Hello,
I try all here now over 3 hours. Not any solution for me.
Can i Downgrade to the Version 15.0.4 ?

Every Nextcloud Update make me big Headache.

Thanks for the tips but nothing working for me.

0 Likes

#88

Yes, when you upgraded the upgrade wizard would have backed up your previous installation. Just check the docs to see how to downgrade. Be careful if your data folder is inside the nextcloud home though - you might end up losing recent files. Having said that the error messages don’t seem to affect anything useful - it looks like they’re to do with sharing between different clouds.

I’ve tried everything too to get rid of the error messages but nothing works for me either.

0 Likes

#89

it is a pity. Nextcloud is fine but every update is causing problems. If you depend on the cloud, it is not really useful. The calendar did not work on the last upgrade. I have invested 2 days and it still does not work. Now I have to change everything to another calendar.

I’m thinking about switching to seafile again, that ran many years without any problem.

0 Likes

#90

and the next problem…
Letzte Cron-Job-Ausführung: Vor 10 Stunden. Möglicherweise liegt ein Fehler vor. Überprüfe Cron-Job Einstellungen

0 Likes

#91

What went wrong with your calendar? I ignore the /.well-known.carddav auto discovery malarkey and just use normal CalDAV links like https://xxxx.synology.me/yyyy/nextcloud/remote.php/dav/principals/users/zzzz / where xxxx is my Synology ddns username, yyyy is the port I use externally which forwards to port 443 internally and yyyy is my Nextcloud username. This link works over my MacOS, iOS, Android and Windows devices and I’m using Nextcloud 15.0.5. It has continued working over several updates of Nextcloud.

0 Likes

#92

if I make a calendar entry, it will not be saved. i try from windows, android and webinterfache.
The /.well-known.carddav have allready fixed.

i Used Apache and Nextcloud 15.0.5. before Update is the same problem.
Nextcloud 14.xx not have any problems with the calendar.
I Install a new Ubuntu and a new Nextcloud 15. for two times already.

But this Thread is not the Calendar problem. ```
ocm-provider | ocs-provider

0 Likes

#93

Hi, I have a shared hosting
PHP version: 7.2.3
Platform: Apache
I tried to add this rule to my .htaccess file:
Redirect 301 /ocm-provider/ /nextcloud_folder/ocm-provider/
Redirect 301 /ocs-provider/ /nextcloud_folder/ocs-provider/
but the warning keeps coming out!
how could i solve? thank you so much

0 Likes

#94

I solved this on Nextcloud 15.05 on Ubuntu 16.04 and Apache 2.4, PHP 7.1 Our installation is at /var/www/html/nextcloud and our web base directory is /var/www/html. We run a CRM, ERP and other services as subfolders to /var/www/html/.

Solution that worked for me:
link the folders /var/www/html/nextcloud/ocm-provider and /var/www/html/nextcloud/ocs-provider to the webroot /var/www/html like so:
ln - s /var/www/html/nextcloud/ocm-provider /var/www/html
ln -s /var/www/html/nextcloud/ocs-provider /var/www/html

In addition, to pass the reverse proxy required by our ERP, I had to add into my /etc/apache/sites-enabled/nextcloud.conf,
ProxyPass /ocm-provider/ !
ProxyPass /ocs-provider/ !

This removed the warnings for me.

1 Like

#95

Woah!!! After hours of trying out this, that and the other your post put me on the path to a solution which works on a Synology NAS. Thank you timo12357!

On a Synology the web base directory is /var/services/web and the nextcloud installation is /var/services/web/nextcloud. So I used your example to do:

ln -s /var/services/web/nextcloud/ocm-provider/ /var/services/web
ln -s /var/services/web/nextcloud/ocs-provider/ /var/services/web

It worked! I rebooted the NAS to make sure the links survived a reboot and all good.

This is a working solution for those of us using a Synology NAS folks!

1 Like

#96

This one did the trick for me when editing .htaccess was not working. However, I didn’t need to edit the core apache config, just nextcloud’s: /etc/apache2/conf-available/nextcloud.conf. It looks like the alias destinations are shortened to /var/www/nextcloud/ instead of /var/www/nextcloud/oc()-provider/ so I don’t think the last directory is necessary.

0 Likes

#97

Hi everyone in here - it turns out that the setup check here is wrong. Both ocm-provider and ocs-provider don’t need to be routed from the root of the domain. We will fix the setup check and documentation accordingly.

1 Like

#98

Fix for this is in https://github.com/nextcloud/server/pull/14790

1 Like