Why is my Nextcloud frontend so slow?

just one further remark. I was able to deploy my test-instance on a single node docker swarm and so far it is working - i am able to access the frontpage and login. Will make further tests and report back.

I don’t know how to read vmstat and you should be looking inside the VM anyway for this information as the host is not the same thing as the guest.

Context switching is not a good sign either. Context switching is an expensive operation.

Anywho, good luck with this. I would personally trash the entire thing and start from scratch on baremetal or a base installation on KVM/LXC.

I’m getting a headache and pain in the guts when i hear/read baremetal. But when this is my last Option, well sure i would try it again.

I don’t know about KVM/LXC. Are these commercial VM-Solutions? Can i make a host-redundant solution with that?

In case of baremetal, what specs (CPU, RAM) would you recommend for a 5-10 user soho installation, if i want to have load page times between 1-2 s?

Dunno there is no official documentation on this.

I was hoping you could tell from your experience ;-). But maybe that’s a separate thread.

No every installation is different and I certainly haven’t tested low end hardware.

I pushed the memory limit to 1024 on my test instance, but the lowest loading time was around 12s.

After i fiddled around a bit with my browser settings i disabled adblock, privacy badger and the firefox integrated tracking protection for that site. After that changes i was down to ~6s.

Afterwards i disabled all apps, and had a load time of 1.5-2s ! Bingo!

Now, slowly enabling back one app after another i was able to identify some apps, that add a few seconds to the loading time:

  • federation: around 1.5s (irregardless of the app loaded)

Interestingly disabling the following apps made the loading slower (???)

  • Accessibility (~1s)

In summary i disabled the following apps, which i don’t really use and thus reduced the mean loading time from 12s to 4.5s, which is ok for me:

  • Announcement center
  • Federation
  • First run wizard
  • News
  • Nextcloud announcements
  • Phone Sync
  • Privacy
  • Recommendations
  • Social
  • Update notification
  • Usage survey

I’m leaving the memory_limit at the standard value of 512MB as i don’t see a benefit of increasing it.

Thanks a lot for your hints!

2 Likes

Hello, it’s me again :slight_smile:

just wanted to add my latest update on this topic (partly posted also here Nextcloud really slow after installation):

Meanwhile, i made a “bare-metal” test installation on the same host, where my docker container are running. And the bare-metal nextcloud-instance feels lightning fast - sometimes the load times are below 1s. I’m already thinking about moving back to bare-metal or considering the use of VM’s like proxmox. But somehow i still don’t want to give up docker, because i really like the concept.

Hi I know this is an old post but I have NextCloud running on a very low-end Synology NAS although it is slow it’s not too slow for my purposes, wanted to let you know I sovled some performace issues recently I had LDAP running, I disabled this and it’s like night and day, perhaps test this as well

Just my thoughts

1 Like

External S3 access can also make access to Files app very slow when it is set to update every time. In the setting of the s3 integration you can turn that off. It shaved 3-4 seconds off my response time with Files. It is now responding under 1.5 seconds almost consistently (with Redis).

God. I see too much of @Paradox551 type’s that assume we’re morons and need 24/7 “support” from them… our saviours. :anger:

2 Likes

For me the default use of the build-incode Collabora Online Development Edition turns out to be the reason. Tested the docker-compose on different hardware. Slow like hell. Unuseable.

After changing the Collabora Online settings to Use a Demo Server my system is as quick as a direct installation.

Next is to use a Collabora Online instance in my docker-compose.

3 Likes

Sup? I’m new to here. I’m HyunSoo Tony Lee from south korea.

Yesterday, I have tried the next cloud container on my ubuntu vm.
It was too slow to use it when it was connected via web interface or ip address.
googling doesn’t help at all, and I dig into it. here is the solution I’ve found.

  1. additional port has to be open to localhost, and the port number is 9982
    You know the container environment variables! default is that only port 80 is exposed to localhost port. so you have to add one more, 9982 to localhost:9982
  2. disable the app named “builtin CODE” something.
    login to nextcloud web GUI and click on the circled icon on the top right corner and click ‘app’ and find the name CODE something, then ‘disable’ it.

BTW, trusted_domains at the config/config.php is to be modified, so that you can access it remotely.
You may need vi editor, so you have to apt-get update then apt-get install vim first. the IP address or the range at config.php is not the remote client’s ip address or range, it is supposed to be the local ip or ip range where the nextcloud container is running. lookup the interfaces with the command like ifconfig at the container and the container hosting machine.
below is my example. edit it and restart the container.
’trusted_domains’ ==>
array (
‘localhost’,
‘172.17.0.’,
‘192.168.0.

‘127.0.0.*’,
),

that’s it. it should work as it is supposed to be.

It might help to disable collabora: Nextcloud 20.0.2snap2 Interface Incredibly Slow

(as pointed out earlier by @Marcus_Schurstedt)

when you mount the volume (im assuming you have nginx separate from your nextcloud src)
you must use :z for your nginx container as well as your nextcloud service

    nginx:
        image: nginx:stable
        ports:
        - 9001:80
        volumes:
        - ./nginx.conf:/etc/nginx/conf.d/default.conf:ro
        - ./nextcloud:/var/www/html:z

Hi everyone,

just wanted to report back after a while.

Meanwhile i have migrated all of my infrastructure to a proxmox server. That means, that my Nextcloud is running now within a LXC container. And guess what? It runs lightning fast! Now, it is really fun to work with it on a daily base (like checking mails via rainloop).
First i changed my old server (Fujitsu Desktop PC) to run with proxmox. After some time i decided to build an entire new server based on a Ryzen 3 3100 and an ITX Mainboard. The main reason for upgrading my server was to have more RAM (now i have 64GB :blush:).
But as i have now more processing power i also use it for other Tasks like ripping and recoding my BluRay collection.

Cheers

1 Like

I share your pain … :roll_eyes:

Nextcloud and Docker just does not seem to gel. What a shame.

1 Like

I had a similar problem after moving to a containerized (fpm+nginx version in a podman pod with mariadb, redis and collabora) version of Nextcloud and some Google-foo landed me here which wasn’t really helping my case at all. Frankly most of the info here is a bit misleading. For example why would you need port 9982 exposed?

Anywho, for those who have long load times and find this thread I strongly suggest checking your loglevel settings in your config.php. If set to 0 you’re basically DDoS-ing yourself. Another thing you could check is your Mariadb config. This might help you getting a better performance out of you db: Nextcloud 21 mit Apache2 (http/2) und PHP-FPM (fast track) – Carsten Rieger IT-Services

6 Likes

@apinter
Thank you - forgot my loglevel at 0 and was wondering why my nextcloud is pretty slow, your hint pointed in the right direction now it works smoothly with nginx :slight_smile:

setted to 1. and now it’s fast.