White Page after login after updating Deck

Nextcloud version (eg, 20.0.5): 25.0.2
Operating system and version (eg, Ubuntu 20.04): Linux 4.19.0-17-amd64 #1 SMP Debian 4.19.194-3 (2021-07-18) x86_64
Apache or nginx version (eg, Apache 2.4.25): Apache ??
PHP version (eg, 7.4): 8.1.13

The issue you are facing:
After updating deck to version 1.8.2 I get a white page after logging in.
First seen with nextcloud 24 where I only updated deck. I manually downgraded deck to the old version, worked again.
Then, after updating to NC 24.0.8, deck got updated again, white page was back.
I updated to NC 25.0.2 and removed deck. Login works.
After clean reinstall of deck, white page after login is back.

Interesting: When I’m logged in as admin or in second browser as normal user while the update is done, NC works fine until I logout and login again. It is only the login process.

If I could help anyhow in bugfixing, let me know. As this is a shared webhosting, I could not dig to deep into configuration.

Is this the first time you’ve seen this error? (Y/N): N, happened during multiple deck updates

Steps to replicate it:
On my production system, it’s always there after deck install (removed deck now, but I need it)
An all other systems, I do not have any problems.

The output of your Nextcloud log in Admin > Logging:

[PHP] Fehler: Nesting level too deep - recursive dependency? at /var/www/vhosts/hosting159649.ae813.netcup.net/cloud/httpdocs/lib/private/Log/ExceptionSerializer.php#215

PROPFIND /remote.php/dav/files/user/Path
from 92.211.... by user at 2022-12-16T14:56:42+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!): If it could help I post it here…

The output of your Apache/nginx/system log in /var/log/____:

mod_fcgid: stderr: PHP Fatal error: Nesting level too deep - recursive dependency? in /var/www/vhosts/hosting1***.ae813.netcup.net/cloud/httpdocs/lib/private/Log/ExceptionSerializer.php on line 215

Same her on iPhone IOS 15.7.2
IOS Nextcloud Deck App: V 0.13 updated 1 Week ago
Nextcloud version : 25.0.2
Nextcloud Dek App: V1.8.2
Operating system and version: Debian 11
Apache or nginx version: Apache ??
PHP version: 7.4

BTW: Deck on Android works with same Nextcloud

What is the procedure to fix this?

PS: I found This:
Crashing iOS Deck app · Issue #4331 · nextcloud/deck · GitHub
But this is closed!

Pls. let me know where I can find the issue @Github

Some hours of testing and searching the web took me a step closer to the problem.
Circles is not working properly (no “Contact” app installed).
Disabling circles solved the issue.

Hope it will be fixed with #35970

Yes! Many THX for this hint
Now the login screen is displayed

Error loading page
Domain: NSURLErrorDomain
Error Code: -1202

I can access my Nextcloud via NextCloud APP successfully
also an SSL certificate worx in the browser on PC and Android
Access to Deck in Android also possible
What’s the matter here with iPhone

Maybe Deck stuff can ask colleges from NextCloud APP to get the
Knowledge on how to connect their Deck APP?

Someone working on it?

That issue was closed because it was posted in the repository for the server-side app, not the third-party iOS client app.

It appears the author of the iOS client app you’re using prefers to handle issues here: https://framagit.org/StCyr/deck-react-native

If you believe your issue may be related to the previous one you linked to, you may find what appears to be its follow-up issue at the correct repository here with participation from the developer: https://framagit.org/StCyr/deck-react-native/-/issues/89