Uploads "chug" in 10mb segments?

Nextcloud version: 18.0.1
Operating system and version: Raspbian (10) Buster
Apache or nginx version: Apache 2.4.38
PHP version: 7.3.14

I’m running at standard vanilla settings for everything right now, no apache, php or nextcloud customizations. The only thing I changed was post_max_size and upload_max_filesize in php.ini to 8gb to see if it helped - it didn’t.

What I’m experiencing is “chugging” in 10mb segments when uploading and it kills my upload speed. I can upload to the raspberry pi at usually ~80-100mb/s, but here the chugging is destroying the upload speed and the process time overall


Downloads are perfectly fine, I top out at ~100-110mb/s as expected with no “chugging”.

Is this a nextcloud issue or apache/php?

1 Like

Hi! I encountered the same problem when writing to S3 This is due to slow storage (in my case s3, in another case a slow disk). By default, chunk size = 10Mb and when uploading large files to the server in the user’s folder in the “uploads” folder, parts of the file of 10Mb are downloaded. After downloading all the parts, they are collected in one file and transferred to the desired location. Try changing the chunk size or turning it off. For s3, I disabled and the file is written directly without splitting. It also reduce the load on the CPU. But there may be problems about which I do not know yet)
Disable: sudo -u www-data php occ config:app:set files max_chunk_size --value 0
or sudo -u www-data php occ config:app:set files max_chunk_size --value “size”


Thank you so so much!!!

Did it work for you?

I’m using nextcloud 18 on docker and facing the same issue. How do I put this command in the container?

Thank You

I’m using docker and facing the same issue, you can try this command:
" docker exec --user www-data <your container’s id> php occ config:app:set files max_chunk_size --value 0"

To piggy-back off of this, anyone coming here looking for unRAID-specific advice can use docker exec -it nextcloud occ config:app:set files max_chunk_size --value 0 from the main unRAID console

Yes is a fix for some cases but for me not and I still can’t get it
It is uploading many ~10MB chunks, high cpu load etc. How can I fix it omg sucks
I think this would help my friend. Thanks for the answer. Maybe I should check if there is any other app to set 0… :(-

Nextcloud version: 22.2.3
Operating system and version: Debian 9.13 64bit
Apache or nginx version: Nginx 1.19.0
PHP version: 7.4.0

I’m facing the same issue: uploading bigger files and all goes with 10MB chunks.
I checked the php.ini and nginx config → max upload size set for 16G
set: config:app:set files max_chunk_size --value 0
nothing helps, still upload chunks at 10MB

Hi @rwi, you can set the value to ‘’ to disable chunck ( not recommended) :
config:app:set files max_chunk_size --value ''

refresh your web page

to change the value just set the chunck like this : value(Mb)10241024

example : value of 20 Mb 2010241024 = 20971520
so : config:app:set files max_chunk_size --value '20971520'

refresh you web page