Uploading large files fails even with desktop sync client


#42

ssl routines ssl3 read bytes sslv3 alert bad record mac

this loops for eternity; it starts upload, then displays this message, then restarts uploading and goes on like this for eternity


#43

hmm, it seems to have completed the directory upload today, so I guess it’ll upload in the end.


#44

@Jason_Hunter, yes because the client will keep retrying. For me, uploading in Windows exhibits same issue as in Linux

@goober2186 @StephanW
I tried setting SSL logging level to debug and I got these messages in the ssl_error_log

[ssl:info] [pid 27017] [client 73.231.84.54:60408] AH01992: SSL library error 1 reading data
[Wed May 10 02:40:37.780810 2017] [ssl:info] [pid 27017] SSL Library Error: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac

A quick google says I need to disable AES-NI?


#45

@StephanW

I’ve found a fix! So your hint about packet corruption kept bugging me. I didn’t have a spare router on hand so I couldn’t test the theory, but today out of the blue, I suddenly had the idea to try flashing LEDE onto my router instead of using the stock firmware.

I am happy to report that this completely got rid of the issue!

I am not sure why this fixes it. Maybe the stock firmware has a bug or it can’t handle that high throughput?


#46

I am glad you were able to solve it. It could be that there was memory corruption in the router when there is a high data load.

I have seen this before with a company I worked at, where we had a network product which also saw strange behaviour with high load caused bits to change. after investigation we found that the FPGA was using memory allocation which was already assigned to a different task.

But the key thing is you fixed it :slight_smile:


#47

Goodness that must have been a hard issue to investigate!

Anyways, I hope this helps @goober2186 and @Jason_Hunter. It’s not an ideal solution. Flashing firmware can be a scary process or impossible depending on what router you have, but this might be a good solution if you don’t have another router on hand and you’ve exhausted all the other options.


#48

ok, eh, so this is not related to any router on my part, which is a GNU/Linux box


#49

This issue (although solved) kinda sounds like what I had:


#50

@Jason_Hunter

I am assuming you’ve done all the steps in the Setup Guide to enable large uploads? None of those worked for me, which is why we thought it might have been a network hardware issue.

Can you enable PHP debug logging and see if any errors appear?

@aronovgj
Yeah, seems like there’s a bunch of things that can go wrong with file uploads and a lot of them result in the same unhelpful error. For you it was related to timeouts, for me it was packet corruption.


#51

I have a nighthawk R7500v2 running as an AP and a pfsense box. I’ll need to try uploading on a wired connection to rule that out. As far as increasing the request time I’m uploading locally so it never takes more than a minute or two to upload my 1GB test file. I’ve tried increasing all the times for larger uploads. It seems to work just fine outside of my network lol.


#52

@goober2186

I’ve noticed that it would upload fine outside of my network but I would still get one message about webdav exception. When I uploaded from within my network, I would get two messages about webdav, with the transfer failing once the second message happens.

Now that I’ve flashed my firmware I get no messages about webdav in the error logs.

Seeing as how my Nighthawk firmware was buggy, I would suggest you try skipping the Nighthawk and plugging in directly somehow. Maybe the Netgear firmwares are buggy.


#53

ok, so this is the weirdest thing ever.

I subscribed to another nextcloud provider and I see the same error message: sslv3 alert bad record mac error

So, I’m guessing the problem lies with me, then, but how?:wink:

I have an Ubuntu 16.10 bastion host that works as a router/dhcp server and that’s it. It was version 16.04 and I upgraded it to 16.10.

I have multiple computers inside my network and they all show the same error;)

What the hell can the problem be?:wink: Should I try upgrading it to 17.04, but I have concern that it might not make a difference. Is it the network card? I have no clue at this point.


#54

Try directly connecting to the internet and see if it still happens. It could be your router. I have a feeling for me, my stock router firmware couldn’t keep up with the upload speed and was either dropping or corrupting packets. You should try to isolate the issue by removing intermediate steps in between you and the server.


#55

@urbenlegend @StephanW Bypassing the Netgear router solved the problem. What a really weird issue. There isn’t a fully working DD-WRT firmward for my router yet. Le sad. Thanks for all the help!


#56

@goober2186

You can flash LEDE/OpenWRT on there. https://lede-project.org/toh/hwdata/netgear/netgear_r7500_v2


#57

Awesome, thank you, I’ll give that a try!


#58

@urbenlegend Firmware flash successful and issue is resolved! Good find on the netgear router!


#59

@goober2186 That’s great! There’s something seriously wrong with Netgears stock firmware I guess.


#60

I have encountered the same problem. How can I bypass it?
I am also using netgear R7800