Upgraded for 10.0.2 -> 11.0.0: Missing pretty blue folder icons for every folder

Upgraded from 10.0.1 -> 10.0.2 -> 11.0.0 using the following command

sudo -u www-data php occ upgrade

No problems with 10.0.1 -> 10.0.2.

However, 10.0.2 -> 11.0.0 did not product the pretty blue folder icons next to folders

I have read through the other topics. I am not using .htaccess files. And I have chown www-data:www-data nextcloud.

The blue folder image appears to come from this location:
background-image: url(/index.php/apps/theming/img/core/filetypes/folder.svg?v=8);

But there is no such location. Within the path there is: apps/theming/img/app.svg.

In addition there is core/img/filestypes


Interesting. For me the icons appeared directly. My browser terminal found the image file here:
<div class="thumbnail" style="background-image:url(/nextcloud/core/img/filetypes/folder.svg); background-size: 32px;"></div>

Do you have “'theme' => '',” set in your config.php and tried to disable the theming app?

config.php has: " ‘theme’ => ’ ',"

What is meant by disable the theming app?

The file shows up when location has been modified to
url(/core/img/filetypes/folder.svg) The inncorrect or my location is

Why would the incorrect location be given for the icons? Any ideas

OK. @MichaIng I stumbled across what you were telling me: To disable the Theming App.


1 Like

Yeah, “Theming” in app store ;). So it works now? Just thought it’s
worth trying, because your icon url points to inside the theming app folder.

Yep! Kept looking at the url pointing to the theming app folder! But after stumbling on what to do, I realized you were telling me exactly - to disable the Theming app in the App Store. Thanks for your time! :slight_smile: You solved it!

Ok great, you are welcome :slight_smile: .

Please mark one answer as solution, so people will see browsing the support topics.

I check the solution box, green arrow appears and but error message says “resource could not be found” and refresh browser unchecks the solution box.

Sorry to bother any of you guys but I am unable to check any of the replies as solved. When solved is checked an error message appears. I want to make sure I am contributing to the community and helping others.

@tflidd @MichaIng

There is a technical problem and we must wait for an admin to resolve this issue:

Sorry to hijack this thread but I have a similar problem to this after an upgrade to 11.0.
Actually it was an urgent migration from v9 server to a new server running v10. then I performed an upgrade to 11.

My folder icons are missing so following the suggestion above I tried to disable the theming app. However when I go into the apps section the enabled and disabled lists are all empty.

Any suggestions?

I’ve marked post#5 as the solution.

I am strictly new at this. But this is what I can share with you.

I did a manual upgrade 10.0.1->10.0.2->11.0.0

Make sure along the way through the upgrade the original apps are carried/brought/copied over from each successive upgrade. [check that apps/ is not empty]

When I changed the server, actually the server’s name, I noticed this problem per this thread: Fixing Web Notification: MySQL, oc_notifications and link. The old server’s name was in table oc_notifications. The fore mentioned thread explains how to fix that and may provide some insight, if the old server name is stuck in the database table/field.

With “enabled and disabled” lists being empty, there may be a similar problem as with (b) in that (1) an old server name is stuck in the database or (2) the app/ is located in a different location from where it usually is. In other words, there could be a table/field in the database that has the “old server name” as did oc_notifications in the above mentioned thread.

I hope this helps! Good luck and have fun!

Thanks for your suggestions Anthony,
I have scoured the database tables for any path or server references but I’m afraid I cannot find anything pointing to the old server.

I’ll keep digging.
thank you.

Your are welcome.

It is very curious that the “enable and disable” stores appear empty when viewed from the browser. Since apps/ is in the correct location and the files in apps/ are viewable - you can see them - when looking from the server. The only other thing I can think of is the user|permissions or ownership.

Fedora owner is: apache:apache
Ubuntu owner is: www-data:www-data

Compare the user|permissions or owner of the old apps/ with the current apps/. The NC documentations mentions and shows the necessary command to recursively chown.

Anyway good luck. Let me know what you discover! I hope this helps!

Since installing 11.0.2 and with 11.0.3 the following error showed up in the logs each time the page was access or refreshed:

rewrite or internal redirection cycle while internally redirecting to “/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/apps/theming/img/core/filetypes/x-office-document.svg”, client:, server: example.net, request: “GET /apps/theming/img/core/filetypes/x-office-document.svg?v=10 HTTP/1.1”, host: “example.net

The folder icons were also missing. Disabling the Theming app seems to have fixed this issue.

Running: debian 8, nginx 1.10.3, php7.0.