Upgrade stuck in v19.0.12, manually upgrade dont work


i need help. Simple the upgrade to the newest version dont work in any way.
First i tried to update with the updater but there its stuck at the version 19.0.12 and says that this is the newest version.
I tried a manuall update, but that didnt work too.
Removed all files except the config, data and apps folder and executed the upgrade command but there i only get a error, that is weird.

The apache log dont help too.


  • Ubuntu 18.04
  • Apache 2.4.46

I hope anyone can help me. Im really pissed about that and don’t know what to do now.

Kind regards
Timo // NiceKype

Hi NiceKype, did you get this error when trying to update via the built in updater?

You mean your error at the beginning? Yes, the same thing. It says its up to date.

But the last answer in that thread dont work too. I cant upgrade manually too.

to which version did you tried to update? i didnt try the manual thing yet because this is a production server.
They changed something related to the updater it seems in 19.0.12, maybe this is a bug introduced in this version

I want to upgrade from 19.0.12 to the newest version. I think 21.X.
And my cloud is productive too but the downtime from some minutes is okey, if it would work ^^

i dont know if it changed but you can upgrade only 1 mayor version at a time, so you need 19 → 20 → 21. Could you try to restore a backup from 19 and upgrade to 20?

I tried that, but it gave the same error. But i found a interesting part in the error message.

Everything in the message says something within the libs folder but 2 or 3 says its a error in the 3rdparty folder.
And there i found my problem! I replaced everything except the manual installed apps (i tried the upgrade after one folder after another ^^).
Now i have the newest 21 version.

Thanks alot, problem solved!

Danke dir, hast mir wirklich weitergeholfen. Hätte ich das so nicht nochmal probiert, wär mir der Error Teil nicht aufgefallen xD

1 Like