Upgrade from 25.0.11 to 25.0.12 fails

Nextcloud version (eg, 25.0.11/12):
Operating system and version _Debian 11 bullseye arm64:
Apache or nginx version _Apache 2.4.56:
PHP version _8.1:

The issue you are facing:

Unexpected notification of available upgrade to 25.0.12 (I had in my diary for next month).

Selected open updater then start upgrade.

  • Check for expected files

The following extra files have been found:

  • composer.json
  • package.json
  • package-lock.json
  • composer.lock

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Repeated exercise.

The output of your Nextcloud log in Admin > Logging:

No entry today

The issue lies with the updater of 25.0.11 unfortunately. Please remove the mentioned files manually and re-try, c.f. Third RC of Nextcloud 27.1.0 - #18 by blizzz


Thank you - that worked. I was then offered the upgrade to 26.0.7. I did this and it worked with the usual warning about missing indices. I did the usual fix:

sudo -u web9 php occ db:add-missing-indices

To get the errorL

This version of Nextcloud requires at least PHP 8.0
You are currently running 7.4.33. Please update your PHP version.

Well it’s running under PHP 8.1 and wouldn’t be working at all if it was PHP 7.4. Any idea how I can fix this? For info this is a bullseye installation which uses 7.4 but Apache is running the virtual server under 8.1 using the sury repo.

I did try: sudo -u web9 php8.1 occ db:add-missing-indices
But this through an error there was no matching APCu - though there is!

Same issue with the exact same files here, hadn’t an update error since I’ve startet this instance.
Where do I find those mentioned files exactly?

In the Nextcloud root directory

Thanks, that worked for me. Removed the specific files.

1 Like

Did you have to upgrade to PHP8 or stay with PHP7.4?
Thanx in advance.

My Nextcloud instance is already running on PHP 8.0, so this was no issue for me.

I’m still on php 7.4 and the upgrade worked fine after deleting these 4 files :slight_smile:

1 Like

same error
Current version is 26.0.6.
Update to Nextcloud 26.0.7 available. (channel: “stable”)

The same for me! It works