Upgrade 20 -> 21 fails / stucks in step "Delete old files"

Hi @ all,

in past everything (updates/upgrades) works fine with web-installer, so
i tried to upgrade from 20.0.8 to 21.0.0 via web-installer…
Yesterday it stucks in step 4 “create backup” with error: “504 Gateway Time-out” (i didn’t upgrade)
Today i tried again and now it stuck in step 10 " Delete old files" with that same error :frowning:
occ via command line dont’ work, because alle files are deletetd
(occ out of the backup sais: nextcloud is not installed …)

What to do?
Please help :slight_smile:


Check this out: Update to 13 fails - core/shipped.json is not available - #4 by gas85

1 Like

Hi gas85,

i tried that but nextcloud said it wouldn’t be installed (as i wanted to occ upgrade)…
I copied back the files from latest backup an now the old version runs again!
Only one error now: “PHP configuration option output_buffering must be disabled”
For today i have enough :worried:

I think i will wait until 21.0.1 is here for next try…

Thanks a lot :kissing_closed_eyes:

Got it - “cp” didn’t copy “.user.ini”!
Now I’m back to where I was before - puh :sweat:

I learned a lot about Nextcloud today (and also a little bit about linux)!
In any case, I’m always happy that there are such great communities :star_struck:

greets from the
picknicker :cowboy_hat_face:

1 Like

Hi again,

I had waited for 21.0.1 after my problems with 21.0.0 …
However, it seems to me, after I read about so many problems with 21.0.1 while skimming the posts here in the forum, that an upgrade might not be such a good idea at the moment!
Apart from that, the web frontend (in two installations with 20.0.9) still shows me at the moment that I am up to date :innocent:
Conclusion: keep waiting for 21.0.2 …

greets from rainy germany
the picknicker :cowboy_hat_face:

Hi @ all,

i’m happy that version 21.0.2 has been released!
Today I pulled up my two instances :partying_face:
I carried out the updates via the console, which in my opinion just slips better than via the web updater …

A few small things still had to be done after the updates - but most of them were not worth mentioning.

Only in one of the two installations have I not yet received the following message:

 Your web server is not set up correctly to resolve "/.well-known/webfinger". For more information, see the documentation.
 Your web server is not set up correctly to resolve "/.well-known/nodeinfo". For more information, see the documentation.

Didn’t manage to get rid of the messages :thinking:

best regards
the picknicker :cowboy_hat_face:
(i like the cowboy hat face)

Actually it is disabled by default:

; output_buffering
;   Default Value: Off
;   Development Value: 4096
;   Production Value: 4096

Glad to hear that it works for you :slight_smile: