Updated Collabora, now unable to open documents

Hi guys,

I ran into the same problem. Using the exact same config for apache as suggested by you guys and I still run into that exact problem: can’t create new docs and can’t edit existing docs.
I also sopped and started the docker container (docker stop and docker start .
Did not help either.
Any suggestions what I did wrong?
Thanks :slight_smile:

Hello Christoph,

I hope I am not trying to teach you to suck eggs, but after you have stopped the docker container you need to run a new container. Otherwise I am not sure what can help.

docker ps
[ from the output you can glean the Container ID of your Collabora Online docker image]
docker stop CONTAINER_ID
docker rm CONTAINER_ID
docker run -t -d -p 127.0.0.1:9980:9980 -e ‘domain=cloud\.nextcloud\.com’ --restart always --cap-add MKNOD collabora/code

Dom

Hi Dom,

thanks for your suggestion. A good one in the way that I’m just brand new to docker, so know I’m now that :wink:
But still it did not help :frowning: Did exactly that incl. removing the container this time and start it again with the line you wrote (of course with adapted URL to my cloud).
Still the same problem :frowning:

By the way: here’s the log the container produces…

frk-00033-00 00:02:45.019683 [ loolforkit ] Child 196 has exited, removing its jail '/opt/lool/child-roots/196’
wsd-00024-00 00:02:50.041297 [ loolwsd ] MasterToForKit: spawn 1
wsd-00024-00 00:02:50.041344 [ loolwsd ] Writing to pipe. Data: [spawn 1].
frk-00033-00 00:02:50.017134 [ loolforkit ] readFIFO for pipe: wsd_pipe_rd returned: 8
frk-00033-00 00:02:50.017174 [ loolforkit ] Read line from pipe: wsd_pipe_rd, line: [spawn 1], data: [].
frk-00033-00 00:02:50.017189 [ loolforkit ] ForKit command: [spawn 1].
frk-00033-00 00:02:50.017209 [ loolforkit ] Spawning 1 child per request.
frk-00033-00 00:02:50.017223 [ loolforkit ] Creating 1 new child.
frk-00033-00 00:02:50.017234 [ loolforkit ] Forking a loolkit process.
frk-00033-00 00:02:50.018777 [ loolforkit ] Forked kit [201].
kit-00201-00 00:02:50.019089 [ loolforkit ] Initializing kit
kit-00201-00 00:02:50.019125 [ loolforkit ] Log level is [8].
kit-00201-00 00:02:50.019181 [ loolkit ] Process started.
kit-00201-00 00:02:50.019252 [ loolkit ] Jail path: /opt/lool/child-roots/201/
kit-00201-00 00:02:50.019443 [ loolkit ] symlink("…/lo","/opt/lool/child-roots/201/opt/collaboraoffice5.1")
kit-00201-00 00:02:50.019932 [ loolkit ] link("/opt/lool/systemplate/etc/resolv.conf","/opt/lool/child-roots/201/etc/resolv.conf") failed. Exiting. (errno: Operation not permitted)

Sounds like some permission problems? But what to do with that?

At which environment do you run your dockerimage? Is that a Hypervisor-VM or a OS-based-VM?
Additional please paste the output of the command uname -a

Running it under Debian Jessie - so as I just downloaded the Docker image ans installed Docker from the Debian Repo, I guess it’s an OS Based VM.

Linux ***.de 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2+deb8u3 (2016-07-02) x86_64 GNU/Linux

If I read the other threads correct, I should update the kernel I guess?

Thought about Kernel update… I think the kernel update is only needed on Ubuntu systems, as some 4.x Kernels don’t support AUFS yet. And for Debian, the 4.x Kernel is not even out yet (hopefully coming with Debian 9 in Feb.2017).
And as it seems, my system supports AUFS correctly (see my post here: Issue installing Collabora following official guide)

Hm… not sure what to do :wink:

I needed to upgrade my kernel. After that aufs was gone and I had to remove the container and image and reload docker and the image. After that it worked with the september image of collabora. I didn’t upgrade to the latest image on my debian box yet, only at a ubuntu machine.

To what kernel version did you upgrade on Debian?
Maybe I use a older docker and it may work? where and which one did you get exactly?

on the debian machine I have the Kernel:
4.6.0-0.bpo.1-amd64 #1 SMP Debian 4.6.4-1~bpo8+1
(via source: http://httpredir.debian.org/debian jessie-backports main contrib non-free)
I did not mean docker itself, I mean the collabora-image.
They changed several things in it, I still have issues on another machine with self signed certs.
My primary ubuntu nc host works well with that new image.
The debian host upgrade is in my queue.

Sorry, I surely meant the docker image :smiley:
How do I find an older version? I only get the newest container somehow :wink:
Hm, maybe I’m really going to update the kernel, if you say, that with the 3.16 it won’t work…
But first trying the older collabora/code container.

the only possible thing to get to an older image, is finding anyone with a working one,
who dumps it with docker save and you load it.

Additional the main websocket part in the Apache config is a bit different, anyhow I suggest you try out the actual image, as it cannot get worse for you, than it is now.

true.
I justed tried something else: I started the docker daemon with devicemapper as storage driver, instead of aufs…
and well, now it seems to work :slight_smile:

Can you please specify how you did start the docker daemon with devicemapper?
I am using debian 8 and sure, I can start the daemon manually with “$dockerd --storage-driver=devicemapper”, but I do not get it working with /etc/init.d/docker…

Hi,

I can’t also open any document.

I have this error in docker logs:

wsd-00024-00 09:56:55.653667 [ loolwsd ] MasterToForKit: spawn 1
wsd-00024-00 09:56:55.653777 [ loolwsd ] Writing to pipe. Data: [spawn 1].
frk-00033-00 09:56:55.615596 [ loolforkit ] readFIFO for pipe: wsd_pipe_rd returned: 8
frk-00033-00 09:56:55.615713 [ loolforkit ] Read line from pipe: wsd_pipe_rd, line: [spawn 1], data: [].
frk-00033-00 09:56:55.615766 [ loolforkit ] ForKit command: [spawn 1].
frk-00033-00 09:56:55.615837 [ loolforkit ] Spawning 1 child per request.
frk-00033-00 09:56:55.615901 [ loolforkit ] Creating 1 new child.
frk-00033-00 09:56:55.615954 [ loolforkit ] Forking a loolkit process.
frk-00033-00 09:56:55.624987 [ loolforkit ] Forked kit [2114].
kit-02114-00 09:56:55.625401 [ loolforkit ] Initializing kit
kit-02114-00 09:56:55.625552 [ loolforkit ] Log level is [8].
kit-02114-00 09:56:55.625691 [ loolkit ] Process started.
kit-02114-00 09:56:55.625942 [ loolkit ] Jail path: /opt/lool/child-roots/2114/
kit-02114-00 09:56:55.626586 [ loolkit ] symlink("…/lo","/opt/lool/child-roots/2114/opt/collaboraoffice5.1")
kit-02114-00 09:56:55.627452 [ loolkit ] link("/opt/lool/systemplate/etc/resolv.conf","/opt/lool/child-roots/2114/etc/resolv.conf") failed. Exiting. (errno: Operation not permitted)
frk-00033-00 09:56:56.626311 [ loolforkit ] Child 2114 has exited, removing its jail ‘/opt/lool/child-roots/2114’

Any idea what can I do?

kit-02114-00 09:56:55.627452 [ loolkit ] link("/opt/lool/systemplate/etc/resolv.conf","/opt/lool/child-roots/2114/etc/resolv.conf") failed. Exiting. (errno: Operation not permitted)

Probably you are running docker with a kernel, which does not support capabilities on docker file system.
On https://www.collaboraoffice.com/code/ there is a note:

This docker image does not work on Ubuntu 14.04 LTS, because Ubuntu
14.04 LTS has missing kernel compile option CONFIG_AUFS_XATTR=y, which
is leading to setcap not working on docker’s aufs storage. Upstream bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1557776

I have Ubuntu 16.04 installed.

I see the new kernel can be tested…

I too facing the same problem. My ubuntu uname -a details are

`Linux jbkinfotech-Lenovo-G570 4.2.0-27-generic #32~14.04.1-Ubuntu SMP Fri Jan 22 15:32:26 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux`

So as per above comments, just want to confirm, upgrading kernel will help me to fix the problem?

My docker details below:

sudo docker info
Containers: 1
 Running: 1
 Paused: 0
 Stopped: 0
Images: 3
Server Version: 1.12.1
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 16
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: null host bridge overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options: apparmor
Kernel Version: 4.2.0-27-generic
Operating System: Ubuntu 14.04.4 LTS
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 2.818 GiB
Name: developer-Lenovo-G570
ID: xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No swap limit support
Insecure Registries:
 127.0.0.0/8

It looks like this was not updated for the NGINX tutorial. Do you have any suggestions to fix this on NGINX?

1 Like

Hello,

It seems after updating collabora it cause a problem for me too.
I’ve corrected the URL scheme and apache main websocket settings.
Now when I want to open a document I got a connection error message…“please try later”, then I click “ok” on the message box and soon the document opens.
In the log file I have fond this:
wsd-00024-04 00:05:06.490725 [ prison_ws_0004 ] Missing JSON property: 'UserId' wsd-00024-04 00:05:06.490853 [ prison_ws_0004 ] Missing JSON property: 'UserFriendlyName' wsd-00024-04 00:05:06.490938 [ prison_ws_0004 ] Missing JSON property: 'UserCanWrite'What have i just missed?
Thanks for the reply!