Update php to 7.4


To upgrade from Nextcloud 23 to 24 I need to have php 7.4. My current version is 7.3.31-1
Can you please inform me what would be the best way to do the upgrade?
Thanks in advance

Provide some more info on your setup. If want assistance.
NCP is already using php7.4 when using latest image afaik.

I have version 1.49 of nextcloudpi and Raspbian

More infos

|NextCloudPi version|v1.49.0|
|OS|Raspbian GNU/Linux 10. 5.10.103-v7l+ (armv7l)|
|USB devices|sda sdb|
|data in SD|no|
|data filesystem|btrfs|
|data disk usage|461G/1.9T|
|rootfs usage|6.2G/15G|
|Nextcloud check|ok|
|Nextcloud version||
|HTTPD service|up|
|PHP service|up|
|MariaDB service|up|
|Redis service|up|
|HPB service|up|
|Postfix service|up|
|internet check|ok|
|port check 80|open|
|port check 443|open|

if I run the command:php -v I get the following result

PHP 7.3.31-1~deb10u1 (cli) (built: Oct 24 2021 15:18:08) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.31, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.31-1~deb10u1, Copyright (c) 1999-2018, by Zend Technologies
````Texte préformaté`

can I use this tuto please to update ?

Looks like you didn’t do the upgrade to Debian 11 yet. With this update also the php update is done.
The update to Debian 11 is necessary to provide further security updates. It can be done the command ncp-dist-upgrade.
Please backup all your data before the upgrade. It runs almost always without issues but we can’t test every combination of apps for example.

Also advise to upgrade to 64bit hardware, as some apps no longer support 32bit.

Thanks to both of you for the explanations
I’ve already tried to do the update, and I always get an error. Every time I have to restore everything.
I’ll do it again and put the error here

OliverV, how do you upgrade to 64bit?

here is the error
sed: impossible de lire /etc/systemd/system/dhcpcd.service.d/wait.conf: Aucun fichier ou dossier de ce type
Something went wrong. Fix it and try again

ls /etc/systemd/system/
In the folder “system” I don’t have a dhcpcd.service.d folder, but dhcpcd5.service

the dhcpcd5.service folder is empty
ls /etc/systemd/system/dhcpcd5.service

The upgrade to 64 bit requires a fresh installation. You need to make a backup of your instance. Install the image again. 64 bit is now default. Load your backup.

Remember to check first if your device is capable of 64bit.

I have 461G of data, so to restore all of it takes a lot of skill.
I have already tried, without success. I don’t remember the error.
I did it like this:

  1. last image on the sd card
  2. plug in the disk that will collect the data, problem it is not recognized, in my opinion I have to format it and move the data to it, the problem is that I risk losing all my data if the operation goes wrong. So I don’t want to try.
  3. the second disk with the backup, it is not recognized either, it must be mounted and I don’t know how

Maybe the easiest thing for me right now would be to fix dhcpcd.service.d

You can follow this guide.
Moving from armhf (32bit) to arm64 (Pi 4).

NextcloudPi Documentation

Excellent, I will follow it as soon as I have time.
Thank you very much!