"Unknown timezone" error message


#1

Hello,

I just upgraded from OC 9.0 (debian package from owncloud.org) to NC 10.0. Everything runs apparently smoothly (no error message) and I did not detect any issue at first. However, when I now try to connect to the calendar app, I get the following error message : “Vous êtes dans un fuseau horaire inconnu (Europe/Berlin), retour à UTC”.

Firefox JS console shows :

GET XHR https://[…]/index.php/apps/calendar/v1/timezones/EUROPE/BERLIN.ics [HTTP/1.1 404 Not Found 33 ms]

And I can see similar things in the server logs:

[error] 18869#0: *10734 open() “/index.php/apps/calendar/v1/timezones/EUROPE/BERLIN.ics” failed (2: No such file or directory), client: […], server: […], request: “GET /index.php/apps/calendar/v1/timezones/EUROPE/BERLIN.ics HTTP/1.1”, host: “[…]”

Calendars are not accessible anymore: the spinning wheel icon next to the calendar name is displayed and no event showed.
I will be happy to give more insights to help find the culprit. Let me know…

Thanks in advance,
Regards,


#2

It looks like you’re missing the timezone files that are included in the calendar app. See https://github.com/nextcloud/calendar/tree/master/timezones/

Did you update the calendar app when you updated Nextcloud? See if there is an update by visiting Apps -> Enabled -> Calendar.


#3

No, I’m not missing these files. They are all present on the server, for instance:

[…]/apps/calendar/timezones$ ll EUROPE-BERLIN.ics
-rw-r–r-- 1 www-data www-data 356 sept. 19 21:54 EUROPE-BERLIN.ics

However, NC is looking for EUROPE/BERLIN.ics, which is failing.

Currently, Calendar shows 1.4.0 version, so the last released version.

For the record, I carefully applied the instructions there Migrating from ownCloud to Nextcloud.


#4

Ahh, good catch. I did not notice that the first time through, sorry.

Can you test with a new user account and calendar? I wonder if it’s something broken in the calendar, or something in the current calendar data.


#5

No luck…
With a fresh user, I get the same error message and the events don’t appear with a continuous spinning wheel.


#6

For the record, I remember having faced a similar issue with OC. Was solved by #524 pull request in owncloud/calendar github repo.


#7

I tried to do a migration from ownCloud 9 to Nextcloud 10 to test this, but it’s running into version downgrade issues. I’ve not been able to replicate the calendar issue with a clean install of Nextcloud 10.

For sake of testing, could you try doing a clean install of Nextcloud 10 and then importing your calendars?

You may want to check https://github.com/nextcloud/calendar/issues for related issues or open your own bug report.


#8

OK, thanks for the effort.
Since I’ve already checked the issues in github before coming here, I will open a new issue.