Unknown error guest upload on version 18.0.2


nextcloud version 18.0.2 after upgrade from 18.0.1
php version: 7.2
Ubuntu version: 18.04 LTS
RAM: 6 Gb
CPU: 2 x CPU
Platform: vmware
Apps used: Group Folder App

Issue: When a guest user uploads a file, he/she will get the error unknown error. The Upload is done to a shared Group Folder. The log shows then a following entry

Exception":“Symfony\Component\Routing\Exception\RouteNotFoundException”,“Message”:"Unable to generate a URL for the named route “photos.page.index” as such route does not exist.

I’ve followed the following solution, which didn’t work:

I’ve checked also the paths, they are correct. However do we need the “/” at the end of the paths or not??
The override did not work

I have this issue on 18.0.2, but not on Version 18.0.1. So this is for me a absolute BUG on 18.0.2 which should be solved in 18.0.3 or whatsoever

BTW I have php 7.2 and not php 7.4





I just investigated again, the version 6.0.3 of Group Folders is buggy and leads external guest to errors.

They have to refresh their browser to see the file is upload and the can’t delete their uploaded files.

So stay away from it. Update NC to 18.0.2 but DO NOT Update the Group Folders app to 6.0.3, After Update NC to 18.0.2, downgrade the Group Folders App to 6.0.1.

Don’t worry, you don’t loose your group folder shares and permissions after downgrade.


and this is the error

Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route “photos.page.index” as such route does not exist.

Error | public | Error: Call to undefined method OCP\Files\Cache\CacheInsertEvent::setPath()/var/www/nextcloud/3rdparty/symfony/event-dispatcher/EventDispatcher.php - line 247:OCA\GroupFolders\CacheListener->onCacheEvent(OCP\Files\Ca … {}, “OCP\Files\ … t”, Symfony\Comp … {})/var/www/nextcloud/3rdparty/symfony/event-dispatcher/EventDispatcher.php - line 73:Symfony\Component\EventDispatcher\EventDispatcher->callListeners([ Closure {},Closure {}], “OCP\Files\ … t”, OCP\Files\Ca … {})/var/www/nextcloud/lib/private/EventDispatcher/EventDispatcher.php - line 80:Symfony\Component\EventDispatcher\EventDispatcher->dispatch(OCP\Files\Ca … {}, “OCP\Files\ … t”)/var/www/nextcloud/lib/private/EventDispatcher/SymfonyAdapter.php - line 63:OC\EventDispatcher\EventDispatcher->dispatch(“OCP\Files\ … t”, OCP\Files\Ca … {})/var/www/nextcloud/lib/private/Files/Cache/Cache.php - line 305:OC\EventDispatcher\SymfonyAdapter->dispatch(“OCP\Files\ … t”, OCP\Files\Ca … {})/var/www/nextcloud/lib/private/Files/Cache/Wrapper/CacheWrapper.php - line 130:OC\Files\Cache\Cache->insert("__groupfold … f", { mimetype: … “})/var/www/nextcloud/lib/private/Files/Cache/Wrapper/CacheJail.php - line 123:OC\Files\Cache\Wrapper\CacheWrapper->insert(”__groupfold … f", { mimetype: … “})/var/www/nextcloud/lib/private/Files/Cache/Wrapper/CacheWrapper.php - line 130:OC\Files\Cache\Wrapper\CacheJail->insert(”*** sensiti … ", { mimetype: … “})/var/www/nextcloud/apps/groupfolders/lib/Mount/RootEntryCache.php - line 57:OC\Files\Cache\Wrapper\CacheWrapper->insert(” ** sensiti … ", { mimetype: … “})/var/www/nextcloud/lib/private/Files/Cache/Wrapper/CacheWrapper.php - line 130:OCA\GroupFolders\Mount\RootEntryCache->insert(” ** sensiti … ", { mimetype: … “})/var/www/nextcloud/lib/private/Files/Cache/Wrapper/CacheWrapper.php - line 130:OC\Files\Cache\Wrapper\CacheWrapper->insert(” ** sensiti … ", { mimetype: … “})/var/www/nextcloud/lib/private/Files/Cache/Wrapper/CacheWrapper.php - line 116:OC\Files\Cache\Wrapper\CacheWrapper->insert(” ** sensiti … ", { mimetype: … “})/var/www/nextcloud/lib/private/Files/Cache/Scanner.php - line 293:OC\Files\Cache\Wrapper\CacheWrapper->put(” ** sensiti … ", { mimetype: … “})/var/www/nextcloud/lib/private/Files/Cache/Scanner.php - line 222:OC\Files\Cache\Scanner->addToCache(” ** sensiti … ", { mimetype: … “}, -1)/var/www/nextcloud/lib/private/Files/Cache/Scanner.php - line 337:OC\Files\Cache\Scanner->scanFile(” ** sensiti … “, 3, 5554, false, false)/var/www/nextcloud/lib/private/Files/Cache/Updater.php - line 124:OC\Files\Cache\Scanner->scan(” ** sensiti … “, false, 3, false)/var/www/nextcloud/apps/dav/lib/Connector/Sabre/File.php - line 291:OC\Files\Cache\Updater->update(” ** sensiti … “)/var/www/nextcloud/apps/dav/lib/Connector/Sabre/Directory.php - line 156:OCA\DAV\Connector\Sabre\File->put(null)/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 1096:OCA\DAV\Connector\Sabre\Directory->createFile(” ** sensiti … “, null)/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 525:Sabre\DAV\Server->createFile(” ** sensiti … *", null, null)<>Sabre\DAV\CorePlugin->httpPut(Sabre\HTTP\R … "}, Sabre\HTTP\Response {})/var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105:call_user_func_array([ Sabre\DAV\ … “], [ Sabre\HTTP … }])/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479:Sabre\Event\EventEmitter->emit(“method:PUT”, [ Sabre\HTTP … }])/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254:Sabre\DAV\Server->invokeMethod(Sabre\HTTP\R … “}, Sabre\HTTP\Response {})/var/www/nextcloud/apps/dav/appinfo/v1/publicwebdav.php - line 109:Sabre\DAV\Server->exec()/var/www/nextcloud/public.php - line 81:require_once(”/var/www/ne … p”)`

Update 2

the funny thing is, even if you update NC to 18.0.3 and leave group folders at 6.0.1, you’ll get above errors, and upload to a public share indicates an unknown error.

So my conclusion, that Groupfolders 6.0.1 will run smoothly with NC 18.0.1, but will not run with 18.0.3. Did not test with 18.0.2, but I guess it’s the same. Group folders 6.0.3 wil also NOT work with NC 18.0.3

So stay away from NC 18.0.3/.0.2 with Groupfolders 6.0.3/6.0.1

NC 18.0.1 is fine with Group Folders 6.0.1



How do you do that?
Is a guest user one that does not have an account?

A guest user, is a user in NC, who is invited from a NC User via E-Mail who has an account. I guess some call it public share.



Hi there,

Can u explain how to do that?
Thank u very much.

Best regards,

hey fibtab,

  1. just remove the app 6.03 from the apps management from NC. Don’t worry, your groups and permissions will be NOT deleted
  2. download the 6.0.1 group folder app
  3. untar and copy it to the nc apps folder
  4. set permission fot the app : chown -R www-data groupfolder, chrgp -R www-data groupfolder
  5. Back into app management: Just activate the app, NOT Update to 6.0.3
  6. Your previous folders will be there again including permisssion and groups

I tried this several times and it worked



1 Like

Hi t-info,

thanks for the fast reply. I tried - with backup before - an update of nextcloud to 18.0.3 with groupfolders 6.0.3 and it worked.

Found that issue also here: https://github.com/nextcloud/groupfolders/issues/827

But anyway good to know. But i’m wondering where the groupfolders directory is. I can’t find it in the “apps” directory.

I’m running a nextcloud docker with a volume on /var/www/html.

Best regards,

I found it myself. It’s under “custom_apps”.

Thanks again @t-info


can you explain me in detail, about what you have done to fix this issue. The github site is not very explaintory.

Like this Step 1, step two.

actual I’m running NC 18.0.1 wit Group Folders 6.0.3



Hi Mesiah,

i read there “So, all Updates went well and NC is running in version 18.0.3 with Groupfolders app version 6.0.3.”
So i tried the Update of NC to 18.0.3 with the actual groupfolders version 6.0.3 and it works well again.

But u wrote:

So u already tried NC 18.0.3 with Groupfolders 6.0.3 without succeed?

Best regards,

Nope, I tried this now, updated to 18.0.3 and automatically update Group folders to 6.0.3, this didn’t help.

So I don’t know what happens. This is error log of nextcloud, when I try to upload a file as a external to an public share anbd I don’t know what the heck this means, I have to revert to the snap shot 18.0.1, since it is a productive system:

Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route “photos.page.index” as such route does not exist.

  1. /var/www/nextcloud/lib/private/Route/Router.php - line 339:Symfony\Component\Routing\Generator\UrlGenerator->generate(“photos.page.index”, [], 1)

  2. /var/www/nextcloud/lib/private/URLGenerator.php - line 82:OC\Route\Router->generate(“photos.page.index”, [])

  3. /var/www/nextcloud/lib/private/NavigationManager.php - line 293:OC\URLGenerator->linkToRoute(“photos.page.index”)

  4. /var/www/nextcloud/lib/private/NavigationManager.php - line 114:OC\NavigationManager->init()

  5. /var/www/nextcloud/apps/theming/lib/ThemingDefaults.php - line 182:OC\NavigationManager->getAll(“guest”)

  6. /var/www/nextcloud/lib/private/legacy/defaults.php - line 263:OCA\Theming\ThemingDefaults->getShortFooter()

  7. /var/www/nextcloud/lib/public/Defaults.php - line 169:OC_Defaults->getLongFooter()

  8. /var/www/nextcloud/core/templates/layout.guest.php - line 55:OCP\Defaults->getLongFooter()

  9. /var/www/nextcloud/lib/private/Template/Base.php - line 179:include("/var/www/ne … p")

  10. /var/www/nextcloud/lib/private/Template/Base.php - line 151:OC\Template\Base->load("/var/www/ne … p", null)

  11. /var/www/nextcloud/lib/private/legacy/template.php - line 181:OC\Template\Base->fetchPage(null)

  12. /var/www/nextcloud/lib/private/legacy/template.php - line 212:OC_Template->fetchPage(null)

  13. /var/www/nextcloud/lib/private/Template/Base.php - line 132:OC_Template->fetchPage()

  14. /var/www/nextcloud/lib/private/legacy/template.php - line 333:OC\Template\Base->printPage()

  15. /var/www/nextcloud/public.php - line 94:OC_Template::printExceptionErrorPage(Error {}, 500) März 27, 2020 08:08:30
    Error public Error: Call to a member function getUID() on null

  16. /var/www/nextcloud/apps/activity/lib/FilesHooks.php - line 638:OC\Files\View->getOwner("/Kundenname … f")

  17. /var/www/nextcloud/apps/activity/lib/FilesHooks.php - line 190:OCA\Activity\FilesHooks->getSourcePathAndOwner("/Kundenname … f")

  18. /var/www/nextcloud/apps/activity/lib/FilesHooks.php - line 165:OCA\Activity\FilesHooks->addNotificationsForFileAction("/Kundenname … f", “file_deleted”, “deleted_self”, “deleted_by”)

  19. /var/www/nextcloud/apps/activity/lib/FilesHooksStatic.php - line 63:OCA\Activity\FilesHooks->fileDelete("/Kundenname … f")

  20. /var/www/nextcloud/lib/private/legacy/hook.php - line 111:OCA\Activity\FilesHooksStatic::fileDelete({ run: true, … "})

  21. /var/www/nextcloud/lib/private/Files/View.php - line 1275:OC_Hook::emit(“OC_Filesystem”, “delete”, { run: true, … "})

  22. /var/www/nextcloud/lib/private/Files/View.php - line 1145:OC\Files\View->runHooks([ “delete”], “/Kundenname … f”)

  23. /var/www/nextcloud/lib/private/Files/View.php - line 716:OC\Files\View->basicOperation(“unlink”, “Lieferschein 2019-10589.pdf”, [ “delete”])

  24. /var/www/nextcloud/apps/dav/lib/Connector/Sabre/File.php - line 448:OC\Files\View->unlink(“Lieferschein 2019-10589.pdf”)

  25. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Tree.php - line 179:OCA\DAV\Connector\Sabre\File->delete()

  26. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 287:Sabre\DAV\Tree->delete(“Lieferschein 2019-10589.pdf”)

  27. <>Sabre\DAV\CorePlugin->httpDelete(Sabre\HTTP\R … "}, Sabre\HTTP\Response {})

  28. /var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105:call_user_func_array([ Sabre\DAV\ … "], [ Sabre\HTTP … }])

  29. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479:Sabre\Event\EventEmitter->emit(“method:DELETE”, [ Sabre\HTTP … }])

  30. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254:Sabre\DAV\Server->invokeMethod(Sabre\HTTP\R … "}, Sabre\HTTP\Response {})

  31. /var/www/nextcloud/apps/dav/appinfo/v1/publicwebdav.php - line 109:Sabre\DAV\Server->exec()

  32. /var/www/nextcloud/public.php - line 81:require_once("/var/www/ne … p")

so just reverted back to 18.0.1 with GF 6.0.1, woks cool now, but this is a situation, I cannot hold longer

I’m sorry - i’m quit new to nextcloud. I only can tell u from my experience and that NC 18.0.3 and GroupFolders 6.0.3 works for me.

Hope someone else can help further.

Best regards,

Hello Fabian,

have you tried to upload a file as an external invited public user? Like you send an public share to an external user, and he she tries to upload some files and gets the above error?

I mean if you disable the the “Activity” app the error won’t show up. But this is not a solution at all.
Cause many others have the same issue too



Hello !
Are you running Nextcloud withn Nextcloud ?
Because I have quite the same experience than you, but only within Docker.
Without Docker it is fine for me.


Hello all

I can confirm now, that GF with Version 6.0.4 is working now:

  1. Upload to public share is without an error
  2. deletion of an file in the public share is without an error
  3. File drop is on my installation of Nextcloud (no docker, just VM) is without an error



Great news.
Is your https://github.com/nextcloud/server/issues/20129 related ?
Shouldn’t it be closed ?