Unable to use webdav mount on windows 8.1

Hi EveryOne
I have facing this issue long time.i can’t use webdav on windows. it showing error
"the folder entered does not appear to be valid. please choose another location."
when trying to add New Network Location.

And when try to map a network location show this error
" error code 0*80070043.The network name cannot be found."
Thanks for your Help in advance.

You need two things to make it works :

1- you must have a valid SSL cert in your nextcloud instance.

2- some times the windows network connection drive isn’t working properly, and you have to write the good url.

The thing who works for me.
Go in your desktop, right click new shortcut.
My user name in nextcloud is brice, so the path you have to enter :

After that went opening the folder, you will be prompt to enter login and password.

Hi nemskiller
i have created shortcut using your method but it goes on firefox and ask u.name & pwd then i entered my login details after that says " This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client."

I have valid letsencrypt certificate and my domain name is “https://nextcloud.gq” like this.

You right, Excuse me, it was early in the morning, i didn’t think well, so here is the solution :

Go to connect a network drive and here is the path :


Example :


Tested just one minute before on Windows 10

I made mistake…
Now again i test with windows 8.1 again normal webdav is working but in server 2012 R2 not working with any method including your’s also…!!!

I’ve just made a test on a Windows Server 2012 R2, without problem, working the same as my Windows 10.

Same Error BroUntitled
The Network was not found…

Lets do some troubleshooting on your server.

Where is this server ? In the same lan network than your nextcloud instance ?
Where is your nextcloud instance and what is it ? Real machine, VM, online server ?

Can you telnet on your server 2012 :
telnet mycloud.com 443 ?

My NC server is on google cloud compute enginee.
Windows server 2012 R2 in my local lan system and this is also my system.

Could you create me an account on your nextcloud ? send it to me by Message, i will try if it works on my windows 10 and windows server

Perhaps this will help:

Thanks for the hint but it’s not affiliated with that issue. It’s a misconfiguration on the nextcloud server side.

@karthikjoe created a user test for me.
On windows 10 - server 2012 R2 it doesn’t work but works for my own nextcloud server.

I think htaccess isn’t working for him.

im sorry, but that won’t work on our install either (testing on WS12R2). The url i know of would be

however, if i fill that in directly in my explorer, the same error occurs. Only after i use
net use Y: \cloud.example.com@SSL\remote.php\webdav
it will work.

Maybe you have some other SMB networking configured in your webserver?

Hello @dennis-360ict

On this forum when you’re typing something related to code, highlight your textzone and select “Preformatted Text” because your link isn’t valid as we see it.

For me, Nextcloud 12 User, in order to connect to my instance with webdav it’s this link :

Windows in connect to a network drive : \\cloud.example.com@SSL\DavWWWRoot\remote.php\dav\files\username\
OS X in finder -> Go To -> Connect to server : https://cloud.example.com@SSL/remote.php/dav/files/username/

With of course HTTPS port on 443

1 Like


What I experienced is that Windows is not able to mount webdav volumes behind a Reverse Proxy and SSL Because the SNI (Server Name Indication) is still not supported by the Windows Explorer (not like Internet Explorer, which does support SNI). I think Google might have a Reverse Proxy for all of their cloud services so they don’t have to assign 1 IP for every single customer and therefore you’re not able to mount it.

There’s more information about this:

I didn’t test it with Windows 10 1709 but I can tell you that this problem still existed with 1607. Honestly I don’t think that MS will fix this in older versions.

It explains everything,
My server is on a real server, @karthikjoe is on Google