Unable to download or enable Community Document Server

This step of changing the timeout in the Installer.php file worked for me.

I changed mine from 120 to 360 and I was able to download and install it.

Oh, you are correct. Seems like my shared hosting won’t allow this php function enabled for ‘security reason’.

If the Community Document Server could run without this function, it would be great. Until then, guess i’m stuck with no option here.

Thank you for the finding the answer.

I have a fresh and standard NC 18.03 and I still cannot download/enable Community Doc Server. Not working even with timeout (in Installer.php) of 360 or 720. Is there any fix?

Could you verify that you have the same issue by checking the admin log and sharing the (anonymized) log with here?

Please see below. I don’t see other error when I try to install CDS.

[PHP] Error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 315857416 bytes) at /var/www/html/nextcloud/lib/private/Installer.php#285

POST /nextcloud/index.php/settings/apps/enable
from 126.74.131.58 by admin at 2020-04-14T21:19:30+00:00

Just in case anybody is interested, I made it work. This after tuning some memory size in php.

Error: 134217728 bytes exhausted (tried to allocate 345165344 bytes)
The above solutions did not help me. The way i fixed this issue was to add the following line to my .htaccess file.

“php_value memory_limit 350M”