Ubuntu Core Appliance No connection

I have Nextcloud Ubuntu Appliance on a RPi 3 B (not +) Nextcloud Box
I have latest Clients on both my Manjaro and Windows 10 Dual Boot laptop
All working fine
Except for every time there is a change of lots of files on my Manjaro Laptop I run into the same problem:
After uploading 1 or 2 GB of data from laptop to the Box, the connection is lost
A reboot of the RPi Box gets it going for a bit but then the same thing - connection lost
After a few times of this the connection is not able to be made

I am able to SSH into the box Pi, but none of the versions of the local IP work for a connection

snap logs nextcloud returns:

2021-03-17T09:00:35Z systemd[1]: Started Service for snap application nextcloud.mysql.
2021-03-17T09:00:36Z nextcloud.mysql[27963]: Starting MySQL
2021-03-17T09:00:38Z nextcloud.mysql[27963]: … * The server quit without updating PID file (/tmp/pids/mysql.pid).
2021-03-17T09:00:38Z systemd[1]: snap.nextcloud.mysql.service: Main process exited, code=exited, status=1/FAILURE
2021-03-17T09:00:38Z systemd[1]: snap.nextcloud.mysql.service: Failed with result ‘exit-code’.
2021-03-17T09:00:38Z systemd[1]: snap.nextcloud.mysql.service: Service hold-off time over, scheduling restart.
2021-03-17T09:00:38Z systemd[1]: snap.nextcloud.mysql.service: Scheduled restart job, restart counter is at 316.
2021-03-17T09:00:38Z systemd[1]: Stopped Service for snap application nextcloud.mysql.
2021-03-17T09:00:38Z systemd[1]: Started Service for snap application nextcloud.mysql.
2021-03-17T09:00:38Z nextcloud.mysql[28267]: Starting MySQL

sudo snap logs nextcloud -freturns the same thing repeating itself, AFAICS

sudo snap services
Service                    Startup   Current   Notes
nextcloud.apache           enabled   active    -
nextcloud.logrotate        disabled  inactive  timer-activated
nextcloud.mdns-publisher   enabled   active    -
nextcloud.mysql            enabled   active    -
nextcloud.nextcloud-cron   enabled   active    -
nextcloud.nextcloud-fixer  enabled   active    -
nextcloud.php-fpm          enabled   active    -
nextcloud.redis-server     enabled   active    -
nextcloud.renew-certs      enabled   active    -

Client says no connection - connection refused

Any ideas on how to solve this, please?

@kyrofa , perhaps, please?


Found this NCbox 11.0.3 - Can't connect Mysql - #6 by ebugnet

Last post suggested low SD memory and so I put RPi SD card into Laptop and Gparted tells me the writable partition is full (14.54 out of 14.56 GB used)

However, Disk Usage analyser tells me there is only 1.4 GB on the Writable partition

I then used sudo du -h | grep -P '^[0-9\.]+G' to find out that 13GB of this is in


Under this were folders corresponding to some of my folders that were being uploading from my laptop to Nextcloud when I had the problem

So it looks to me that when I change a lot of files on my laptop (in this case Digikam changed a lot of my photos with face tags) the Nextcloud appliance then stores them temporarily on the actual SD in the RPi before transferring them to the RPi /Nexcloud box external disk?

So, if this is the case, how can I (a) free up the space on my RPi SD card, and (b) stop this from happening in the future?

I think I solved this: