UB 18.04.2 LTS Nextcloud install (SMB and https:// .... config issues)

Would I be correct in my suspicion that you installed using the snap package? If so, there is a serious design flaw in the snap package where it does not include smbclient, and you can’t add it. Installing it via apt does not make it available to the snap installation. The snap installation also has a strange procedure for enabling SSL if I recall.

If you really want to use SMB, you’re going to want install a different way. After finding out snap won’t do SMB, I tried a manual installation, but I was having fits out of Collabora at the time and ultimately moved my setup to docker-compose. Although the docker image also doesn’t include smbclient, you can easily add it or rebuild the image to include it.

You could try the Nextcloud VM, everything is prepared and you just follow the on screen instructions to set it up.

Happy Nextclouding!

In the interest of transparency, I’ll mention that enoch85’s VM is only free up to 40 GB of storage.

I actually do not need local sorage as i used to connect my smb nas to my owncloud. i want to keep the vm as tiny and uncomplicated in maintanance as possible.

But is it not possible to extend the hdd of that vm ?

I tried the vm on my esxi and i must say that its well prepared and has good config tuturials but … als a linux noob i must say that i wonder what i just installed. It has many different config “tools” that is offers to install. It gives me warnings that i do not understand? And i’m lost again …

What do i need to install and what, if possible, add later?

Tried it twice and on both installs i (must be me, not the vm install procedure) screwed up somwhere or something. The result is that that the installation finished but the nextcloud is not reachable.

As Docker or Kubernetes is something i do not want to screw arround with… jet, i’ll try the manual approach again. There must be an easy way to get this working…

!My Owncloud runs on UCS and inside a docker container which gives me headaces everytime something doesn’t work!

For now i’ll stick to the snap install and try to get this working. The mount works once and therefore it should work in general…

Linux … Why easy when you can do it the hard way … (This is a rant, so don’t take me to serious!!!)

It seems to be working right now.
I Followed a comment on the github Issues page of nextcloud/snap and i adeed a few lines to my fstab :

  • i know … you can see my ip and passwords… to lazy to edit :slight_smile:

This for some reason works and even after multiple restarts and poweroffs the share stays connected. How can i make shure this stays that way? I dont even need to refresh the filelist as it seems.

I can’t cd into the directory anymore? (This must be a premission thing “filemode and dirmode” ?

1 Like

is there a way to select custom Signed CA certs (no self signed) in the install process? i dont see it and i want to make sure i’m not missing anything

The VM will setup valid secure TLS from Let’s Encrypt. You will get A+ and TLS 1.2 on any test online.

Just follow the first setup guide. :+1:t2:

what if i have my own cert & dont want to use letsencrypt

The only reasons for not using Let’s Encrypt as I see it are:

  1. You don’t want to open port 80 (for the renewal to happen)
  2. You already have a wildcard certificate

1. All the HTTP traffic are forwarded to HTTPS, so the only thing that hits the server on port 80 are the redirect request. Other than that, the conf you will get with Let’s Encrypt are optimized for security. TLS 1.3 are possible on later versions of Apache, and the cert gets A+ on any test online.

2. Understandable. In that case you have to import your wildcard cert into the VM, and use that in the conf file for Apache.

I’m having the same issue that OP was having. I ran this command and have the exact same output as you, but I still get the message about smbclient not being installed. What am I missing?


If you use the Nextcloud VM, then just run the menu.sh script, choose apps and then SMB-Mount. That will guide you through the whole setup.