Third beta of Nextcloud 26

The third beta of Nextcloud 26 is now available on our download server! :rocket:

As always, help with testing is very much welcome!
If you notice anything out of order, please report back on the appropriate github repository! :bowing_woman:

:three::two:bit support was reinstantiated with this pre-release, so give them machines something nice :wink:

Known issues

  • When you upgrade from 26 Beta 1 or 2, you may need to delete the files webpack.config.js, cypress.config.ts, tsconfig.json and cypress from your Nextcloud root directory, in order to be able to continue with the upgrade.




When I start the web updater, I get this:

The following extra files have been found:


When I remove that files from the installation folder, all works fine.

1 Like

Same problem here.

Did you update from beta 2?
See Second beta of Nextcloud 26 - #8 by blizzz

1 Like

Is it just me, or is the home button under the menu show hide button on the files view for everyone? I have noticed it in all 3 betas, in Firefox, Chrome and Edge.
2023-02-09 15_08_04-Documents - Files - Nextcloud — Mozilla Firefox


Thanks for the reference, I added the info also as known issue now.

1 Like

See [Bug]: Navigation-Close-icon overlaps Folder-up-icon · Issue #36419 · nextcloud/server · GitHub


Yes. If I remember right, the same happened when updating from beta 1 to beta 2.

If you use groupfolders 13.1.1 (which is NOT released for NC26) and have ACLs set, then the update to b3 leads to /apps/files being unusable until you deactivate groupfolders. It worked until lb2 though.

I have customized my .user.ini file after install to account for things like:

max_execution_time = 3600
max_input_time = 3600
memory_limit = 2G
file_uploads = On
upload_max_filesize = 16G
max_file_uploads = 20

and now it fails the integrity check hash test.

I don’t want the defaults in the .user.ini file but that is where we are supposed to make tweaks right?

How do we get NC to see the customizations as valid or skip the integrity test under the Security & setup warnings section?

1 Like

am i the only one that can’t login anymore as user with beta2 and beta3?
weblogin works fine as admin, but when i try to login as a user, it just never loads anything.
It just stays here rotating the little circle, never loading anything:

meanwhile one apache process goes to 100% cpu load.
strace just shows loads of these messages on the apache process:
mmap(NULL, 67112960, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f64ac5ff000
munmap(0x7f64ac5ff000, 67112960) = 0
mmap(NULL, 67112960, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f64ac5ff000
munmap(0x7f64ac5ff000, 67112960) = 0
mmap(NULL, 67112960, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f64ac5ff000
munmap(0x7f64ac5ff000, 67112960) = 0

debug logging prints ZERO messages.
tried brave browser and firefox, so it ain’t the browser.

webdav/caldav is working fine as that user. the nextcloud windows app is also working fine with that user. so it’s just the webgui that’s broken.

i guess i found the solution on my own. way too many authtokens. seems to be a nextcloud problem since years … makes me annoyed and curious why it ain’t properly fixed yet?

SELECT count(*) FROM oc_authtoken WHERE uid=‘XXXX’;

(1 row)

DELETE FROM oc_authtoken WHERE uid=‘XXXX’;

And it works superfast again!

root cause was nextcloudcmd, which i’m calling every 5 minutes to sync a folder with nextcloud. seems like the update from nextcloud 24 to 26 changed something, to make nextcloudcmd generate a new session for each time it is called.
fix for that is to generate a dedicated password for an app, in the settings of nextcloud.

1 Like

No, you are not the only one with this!
Before seeing this, i had found a (german) site about auth tokens and removed old ones with
DELETE FROM oc_authtoken WHERE last_activity <= UNIX_TIMESTAMP(DATE_SUB(NOW(),
INTERVAL 60 day));

It doesn’t seem to be superfast again, but it works better now. Thanks!

No, i’m seeing this, too. Didn’t pay attention yet.

@mr_mr To be clear, you had the same issue with Beta 2, right? Did you also try Beta 1 by chance?

Yes issue came up with Beta 2, and Beta 3 is also affected. Didn’t use Beta 1 at all though.