Test our new work-in-progress upgrader script

#13

Should have said. “A fresh install a few days ago, before 9.0.51 was released” :slight_smile:

1 Like
#14

Could also be caused by some caching as we don’t have enabled the updates officially yet for obvious reasons. You can get around this by adding this to your config file:

'updater.server.url' => 'https://updates.nextcloud.org/updater_server/',

However, there is some more caching in place. So you need to manually change the channels in your admin screen as well then. I’d suggest to switch from stable to beta and back to stable. :slight_smile:

Let me know if that didn’t work! :slight_smile:

#15

@AlfredSK We just added support for different release channels, it requires a little bit more work right now to test since you are on a Nextcloud version that doesn’t do the automatic migration of the channel the config file. But it shouldn’t be hard :wink:

Add the following to your config file:

'updater.release.channel' => 'daily',

And download the newest version of the updater script from https://raw.githubusercontent.com/nextcloud/updater/add-simplified-updater/index.php

#16

This seem to do the trick… however shell_exec is not available for me, does this mean I need to manually do it, or are you working on this too ?

#17

As I understand there is no shell_exec anymore. It’s just copying files to the Application Directory

#18

Hehe. That’s another one, so Nextcloud 9.0.50 and 9.0.51 ship the broken ownCloud updater. To prevent breaking user data it is deactivated in a lot of cases. (if you would have clicked on the button here like you can in ownCloud your instance would get destroyed!)

I just created a revert PR at https://github.com/nextcloud/server/pull/228 for this, for you to test this the easiest way would be to change https://github.com/nextcloud/server/blob/49a916fb46a2281aed818d20a9487b6af7e2b1dc/apps/updatenotification/controller/admincontroller.php#L135 into the following:

‘updaterRequirementsFulfilled’ =>true,

The file for this is apps/updatenotification/controller/admincontroller.php.

That’s correct, unfortunately some things like this check we can’t super easily change. Let’s see what we can do about this to make it as easy as possible for users to update :wink:

Likely it might be an app that can be installed via appstore that ships the corrected code. Also would allow ownCloud users to easily migrate with one click.

Manual installation?
#19

Ok, done this and I could do the update now

if there weren’t this warning :slight_smile:

http://imgur.com/a/xdK2f Album click me

These folders are put into the root of each domain for web statistics reasons.

#20

Yeah. Sadly there is not much here what we can do about this. Our belief is that we don’t want in any case to operate in a case where we could by incident delete user data. That’s something that happened quite often with other updaters.

So the updater will only run in scenarios where we have a very high level assurance that we won’t overwrite user changes. We do recommend users to install Nextcloud in it’s own directory. If that isn’t possible the only thing we can recommend then is a manual update :wink:

#21

Wonderful work, thanks heaps for all your efforts!

A few glitches I noticed:

  • if directory /$NC/data_old is present, the updater stops telling (only) “data_old is present” Why is that: apparently no backup of /data/ is done

  • After the first half of updating the German version carries a spelling mistake: “Nextcloud wird auf Version 9.0.51 aktuallisiert

  • Installation is halted on this page as button “Start Update” does not respond to clicks! :-/

#22

Is it necessary for the install to be in a root folder called “owncloud”? For security reasons I never use default folder / usernames, and my current ownCloud installation is no exception.

If it does need to be in a folder called ownCloud, can I change this, and the path in the config file, upgrade and then change both back?

#23

No. Absolutely not required, in my case it’s simply called www or server or whatsoever. It should also work quite fine with that: If not, that’s a bug and more details would be appreciated.

As long as the file lives in updater/index.php it should automatically use the correct folder name.

#24

Hello!
First post here, but using Nextcloud from the very beginning (what was that, a month yet? :stuck_out_tongue: )

I’ve tried the updater, but it didn’t work for me. I uploaded the script, changed the config file but when launching the updater I get the following error:

Check for write permissions

The following places can not be written to

  • :/var/www/html/nube/updater/…/…
    The following places can not be written to
    *:/var/www/html/nube/updater/…/…

(nube=cloud in Spanish, it’s the directory where I installed Owncloud and now Nextcloud). As far as I know, file ownership is correct.

#25

Ok, I’m at a loss for now: I can call /$NC/updater manually and provide updater secret from config, but this obviously does not trigger the update process either.

#26

That seems like we very a little bit too strictly checking the file permissions. Checking the permissions on the html folder is unrequired. I have adjusted that with https://github.com/nextcloud/updater/commit/fbd3e5ac5d92f114ac4dbd5c826139d0beda2d6b

Can you download the newest version (same link as before) and try again, @polkillas? That would be greatly appreciated :smile:

#27

More information would be appreciated to make it a little bit easier to debug, as in:

  1. Which steps did you exactly do? And from what version to what?
  2. Do you see anything in your web browser network log? if so: What requests are sent when you click the “Start Update” button?
  3. What browser do you use?
#28

I’m not actually seeing the dropdown with the option to change the update channel.

.

#29

Did you by any chance disable the app “Update notification” or disabled it via your config file? Check your apps screen for this please as well as your config file :wink:

#30

OFC, sorry.

I run NC 9.0.50 on shared hosting.
I downloaded the update/index.php and placed it in /$NC/updater
I added the updater server line to config.php
NC setup is /$www/NC for the binaries and /$www/nc_data for NC data directory (I got a feeling, that might proof important)
I went do admin page, changed channel to “daily” and reloaded page
I clicked “Start Updaer” button
Prerequisite checks claimed an (old and obsolete) “data_old” directory being present and stalled.
I deleted said directory
I reloaded the updater and all checks went fine
Updater displayed “about to upgrade to 9.0.51” page and showed a button
Clicking this button is to no avail: no loading, no redirecting no nothing

  • Browser is Iceweasel (Firefox) on Debian Jessie stable
  • Web browser log states “post” with reply “false” - what log entries do you require exactly? I seem to be unable to copy and paste code from the network analyser :frowning:
#31

If you click on that request and then click on “Params”, what do you see as step there? And the response is just a plaintext “false”? Or some more text?

#32

@LukasReschke

  • Params is completely empty
  • plan text “false” …nothing more
  • Important: I just noticed: post action I get only if calling “updater” manually. If pressing button “start update” nothing happens, no post action nothing.