[Talks] problem camera and microphone not working

Hi the Nextcloud team !
When I tried to use Talks 5.0.1 with my 15.0.0 Nextcloud Installation an error appeared saying the permissions to my webcam and microphone weren’t allowed

I looked for an answer and I understand I need to install a TURN Server
I tried to follow the how to here : https://help.nextcloud.com/t/howto-setup-nextcloud-talk-with-turn-server/30794

And I am stuck at step 3… There is no /etc/turnserver.conf

Anyone can help me to fix it ?

How did you install coturn? The Debian and Ubuntu packages should definitely serve the config file, if you installed via source build or other method it might missing, in this case simply create it and add the mentioned settings. AFAIK the default config only serves commented settings and explanations anyway.

The camera and microphone permissions have nothing to do with the TURN server or the Nextcloud server machine/setup at all. This is a client side topic only:

  • You need to configure your browser to allow microphone and camera access for the website. It might be blocked by default for security reasons or the browser might ask.
  • On Windows 10 you need to enable general app camera and microphone access from settings > privacy as well. Even the browser might not be listed with a dedicated switch/toggle, the general toggle above needs to be enabled for desktop browsers to use them.
  • In case test with any other website that uses camera and microphone, at best use https://test.webrtc.org/ directly to as well check connectivity and WebRTC support in general.

Ok thanks @MichaIng
I tried the link you gave me and indeed it seems I’ve got problems with connectivity and WebRTC… All the check point display a red cross…

I did this evening a call on Skype, everything went well…

I am a bit lost… what should I do to make Talks work with my camera and microphone ?

Are you on Windows 10 with the client?

No I am on Ubuntu 18.04 LTS

Ah okay not sure if/how microphone and camera permissions are handled there. Which browser do you use and did it ever prompt/ask for permissions to access camera and/or microphone? Maybe you can search the browser settings for this, at least every modern browser has per-website device permission control.

I use the Brave Browser version 0.57.18 Chromium: 71.0.3578.80 (Build officiel) (64 bits), created by Brendan EICH cofoundeur Mozilla and creator of the javascript language, I love it !
I also tried with Firefox 64.0 (64bits) just to make sure it wasn’t a browser problem

I had the prompt and I allowed the mic and the cam to work. I went to the permissions in Brave and it showed indeed I allowed everything… still not working :cry:

:top: Does anyone has an idea on how to fix it ?

Hey, Tuhadj, I’m having the same problem here, using Ubuntu 18.04. Have you managed to solve it?

Not realising that this topic was already being addressed (attempted) here, I posted similar concerns in the mis-named “Spreed” category. Here’s the link: "Talk" is only texting

We had an similar problem on one of our notebooks.

The solution was, to reenable the camera in windows 10 settings. Note: The camera was disabled by the user in the windows system settings.

Firefox and Chrome show an option to access the camera despite this system setting and even if you grant access to camera and microphone in browser the intialization in talk fails.
If the browser then tries to initialize the camera an exception is thrown “NotReadableError: Failed to allocate videosource”.

Maybe this problem can be mitigated by initialize the micro first, because most users ony disable the camera?