Sync issue using nextcloudcmd


So, here is my problem :slight_smile:

On one side, I’ve compiled and run the nextcloudcmd on my Raspberry Pi and this works perfectly.
On the other side, I have a CIFS NAS mounted on the same Raspberry Pi and can read/write/delete without issues.

My problem starts when I try to sync nextcloud content directly to the NAS. I then have the following errors from the nexcloudcmd program:

bool OCC::SyncJournalDb::checkConnect() possibleUpgradeFromMirall_1_5 detected!
void OCC::SyncJournalDb::commitInternal(const QString&, bool) Transaction commit “checkConnect” and starting new transaction
ERROR committing to the database: "database is locked"
Database Transaction is running, not starting another one!

Looking at some related posts, I tried the following environment variables:
But result was still the same.

I’d be glad if you could help me sort that out.

Thanks for your help.

Do you use the external storage feature to mount the NAS storage or do you mount it via file system? Can you put files via web-interface?
The sync client is used on local storage (of the client) and is not a network drive?


Thanks for your answer.

Some more details on the topology:

Private cloud server
Nextcloud server
---- LAN
Raspberry Pi
nextcloudcmd client
---- LAN

The external storage is mounted using the filesystem. The nextcloud server is not allowed to reach the storage, I'm using the nextcloudcmd to do the bridge between the server on the internet and the storage in my home private network.

Not sure about your last question.
Hope this clarifies my problem.

Normally, I would suggest to ask the developers directly. Unfortunately, NC has no own client developers yet. So you can only report this to the owncloud-client team. Therefore it would be better to reproduce this problem on a complete owncloud setup because for NC issues they don’t know if this problem is related to NC.

@nickvergessen, @jospoortvliet can you help this user somehow, can the client-theming-repo be used for this purpose?

Not really, I think you’re right - the oC guys won’t look at this unless it is done on ownCloud. It could be a bug in the client, yeah, seeing the error message is about the database.