Stuck in Maintenance mode, though according to config file not

Thanks PancakeConnaisseur.

I was answering to ilippert. i think, you should create a new thread for your problem. This is probably why nobody has answered you yet. Then please provide an output of your log or at least click on the “Detailed Log” think in the webpage you screenshot. It might give you hints on what went wrong.

Hi all,
after days of resetting to the original database, resetting to earlier database backups, and original file structures, updated file structures… the following simple change was the solution.

Remove the complete maintenance line from the config file.
'maintenance' => false,
then it worked.

p.s. I had checked several times for multiple lines of the maintenance entry - no! Only one existed.

1 Like

@PancakeConnaisseur @Hauke_Plambeck and @maxxer thanks for your engagement!

Did you removed both of them?

yes, all mentions of maintenance removed.

1 Like

This is how it should work, however I also got stuck. Only removing the maintenance line alltogether got the instance accessible again. I’d assume its a bug.

Just a guess from what i read here: I could imagine the problem beeing the string ‘false’, which will be true on a boolean evaluation.
So in case someone stumbles by here and having the same error: It would be interesting if the config lists boolean false or string ‘false’ and if removing the dashes solves the problem. (and then of course where the upgrade got stuck, to track where it comes from etc.):wink:

1 Like


php occ config:system:set maintenance --value=false does not equal php occ config:system:set maintenance --value=false --type=bool. So I now always need to tell occ that the type is bool, and then it works.

Well - then the solution is probably to use occ maintenance:mode --off which should handle that for you :wink:

1 Like

Restart php - the only thing works for me

I tried the same but nothing changed.
I suppose some cache files are internally maintenained at /tmp.

I tried rebooting the server and it worked :+1:

@fwolfst : I tried rebboting the server . Since it is maintaining some temporary files in its /tmp directory.