Stuck in Maintenance mode after attempt to go to Nextcloud 13

Using the Nextcloud PI version installed via Curl on a Debian Laptop. It worked fine as 12.04 and it took update to 12.05 without any trouble. Version 13 update appeared to fail and now what I get for login screen is

This Nextcloud instance is currently in maintenance mode, which may take a while.

This page will refresh itself when the Nextcloud instance is available again.

Contact your system administrator if this message persists or appeared unexpectedly.

Thank you for your patience.


sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off


Thank you, it seems to work and left me back at version 12.05

Same problem here, due to the download site timing out. I guess there is a problem with the server, or maybe too many people are trying to update right now? Just disable maintenance mode and try updating later.

I hope that is the issue I will let the 12.05 try to pick it up later.

It’s down for the past few hours but I’m sure they are working on it. Probably best to continue in this thread instead: Https:// down?

It is working, took it out of maintenance mode and tried it later and update went through this time with no hanging

I ran into a problem upgrading a NC12 ( install to NC13. Update did its thing successfully, fetched the files, installed them, web interface that shows the “I need to upgrade things” message seems different as well - which gives me the idea that something was upgraded - but no dice on the occ upgrade, command line or via web. That’s where things come to a screeching halt, since that tells me:

Exception: Updates between multiple major versions and downgrades are unsupported.
Update failed

with no apparent way of fixing that. Running the installer again ends in the same manner. Logs show no errors during the update, all steps are green.

This is really annoying, I’ve been using OwnCloud and now NextCloud for quite a while and when it works, it works brilliantly, but I have yet to have an upgrade not fail on me in some way. :frowning:

Any help would be greatly appreciated.

Edit: managed to get things working again, by directly editing the relavant part of the updater. Somehow it figured that my current provider was blank, which meant it started to do things the OwnCloud way. After hard-coding ‘nextcloud’ there, it worked.

This may or may not be caused by the fact that I have an old install that was upgraded from all the way back to OC8…

u r awesome dude

A post was split to a new topic: Upgrade Nextcloud in FreeNAS jail