Step 4 is currently in process. Please reload this page later

I tried to run the updater. I got a Server not responding issue after or during the back up. I think it mat have been due to space availability. How ever i have allocated more space for the cloud but i can not cancel or restart the update procedure i just get this message. I have looked through hundreds of posts here but they go all over the place. Can anyone help? I have manually taken it out of maintenance mode to access admin panel etc. I have no console access on my web host

Step 4 is currently in process. Please reload this page later.

2017-01-25T12:38:28+1100 PRCWBoXn7R [info] POST request for step “4”
2017-01-25T12:38:28+1100 PRCWBoXn7R [info] startStep(“4”)
2017-01-25T12:38:28+1100 PRCWBoXn7R [info] createBackup()
2017-01-25T13:19:41+1100 tBTLZoMU5x [info] request to updater
2017-01-25T13:19:41+1100 tBTLZoMU5x [info] currentStep()
2017-01-25T13:19:41+1100 tBTLZoMU5x [info] Step 4 is in state “start”.
2017-01-25T13:23:32+1100 SNkyCNJRft [info] request to updater
2017-01-25T13:23:32+1100 SNkyCNJRft [info] currentStep()
2017-01-25T13:23:32+1100 SNkyCNJRft [info] Step 4 is in state “start”.
2017-01-25T13:25:52+1100 OIlInppuzm [info] request to updater
2017-01-25T13:25:52+1100 OIlInppuzm [info] currentStep()
2017-01-25T13:25:52+1100 OIlInppuzm [info] Step 4 is in state “start”.
2017-01-25T13:25:55+1100 qF3h6YIpEC [info] request to updater
2017-01-25T13:25:55+1100 qF3h6YIpEC [info] currentStep()
2017-01-25T13:25:55+1100 qF3h6YIpEC [info] Step 4 is in state “start”.
2017-01-25T13:28:23+1100 n7f3Uti0ct [info] request to updater
2017-01-25T13:28:23+1100 n7f3Uti0ct [info] currentStep()
2017-01-25T13:28:23+1100 n7f3Uti0ct [info] Step 4 is in state “start”.
2017-01-25T13:28:25+1100 rICLoz3R5R [info] request to updater
2017-01-25T13:28:25+1100 rICLoz3R5R [info] currentStep()
2017-01-25T13:28:25+1100 rICLoz3R5R [info] Step 4 is in state “start”.
2017-01-25T13:51:34+1100 IaiEp3GWVo [info] request to updater
2017-01-25T13:51:34+1100 IaiEp3GWVo [info] currentStep()
2017-01-25T13:51:34+1100 IaiEp3GWVo [info] Step 4 is in state “start”.


Hi Matthew,
I had the same issue while upgrading (PHP timeout in my case, during step 4 as well). I found somewhere on the forum the suggestion to delete the .step file located here:
nextcloud-data/updater-randomstring/.step (where randomstring is, well, a random string added by the updater).

I was then able to restart and complete the update process.

Hope this helps,


It worked. Thank u

Worked. Thank you!

I had the same error, but i couldn’t find the .step file on my server.

First, i went into the root-directory (cd /), and searched for it with

find -name “.step”

Now you have the filepath and you can rename or delete the file.
I renamed the .step File with

mv “YOUR_FILEPATH.step” “YOUR_FILEPATH.step_backup”

It worked fine for me.
I hope it helps someone.


Just got the same when upgrading from 18 to 19. The above solved my problem. Thanks :slight_smile:

worked fine for me