Stable debian repository


#41

I rebuild repository and now support Jessie and Stretch.

Add in /etc/apt/sources.list

For Jessie:
deb http://apt.jurisic.org/debian/ jessie main contrib non-free

For Stretch:
deb http://apt.jurisic.org/debian/ stretch main contrib non-free

Keyring:

wget -q http://apt.jurisic.org/Release.key -O- | apt-key add -

If wont to install nextcloud client, simple do:

apt-get update
apt-get install nextcloud-client

also for nextcloud server:

apt-get update
apt-get install nextcloud-server

p.s. - Sry. for slow respond. I’m sick and I have a high fiber :sweat:


#42

No need to apologize @ijurisic. I am greatly appreciative of your help, whenever you can get around to it. I hope you feel better, friend!

After adding your repository, I am up and running now! Thank you very much! No more need to log in to Windoze! :slight_smile:

One small thing I noted, was when I first synced, I received the following message:

Not Found
The requested URL /owncloud/status.php was not found on this server.

Apache/2.4.10 (Debian) Server at [my.url.redacted] Port 443

Should I report that as a minor issue to NextCloud devs?

It wasn’t an issue for me, I just extended my base url and added /nextcloud because that’s where my installation resides (instead of /owncloud) and then it went on just fine. But I figure that’s a little leftover detail just probably still hanging around since the fork.


#43

Just wanted to say thanks to authors of nextcloud software and to nextcloud community for creating/maintaining debian repo. Upgraded to stretch and nextcloud-server 12 from ijurisic’s repo few minutes ago.

Thank you! :slight_smile:


#44

Love new update of nextcloud server 12.0.1 !!!

p.s. - Debian repository updated for jessie and stretch.


#45

thanks for the debs. on a fresh install of stretch i did these to get around some issues:

[ trying to format as code not sure If i can figure that out]

indent preformatted text by 4 spaces

apt install apt-transport-https

apt install nextcloud-server php-zip php-mbstring php-ldap

however page set up failed .

mysql needed to be set up

https://wiki.archlinux.org/index.php/Nextcloud
mysql -u root

MariaDB [(none)]> CREATE DATABASE nextcloud DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci;
Query OK, 1 row affected (0.01 sec)

MariaDB [(none)]> CREATE USER nextcloud@‘localhost’ IDENTIFIED BY ‘PASSWORDt’;
Query OK, 0 rows affected (0.00 sec)

MariaDB [(none)]> GRANT ALL PRIVILEGES ON nextcloud.* TO nextcloud@localhost;
Query OK, 0 rows affected (0.00 sec)

aftre that the web page set up worked.


#46

Nextcloud client seems not available:

willi@tolot:~$ sudo apt-cache search nextcloud
nextcloud-server - Nextcloud server: community-driven, free & open
willi@tolot:~$


#47

Repository updated, server 12.0.3. Enjoy :grinning:


#48

Hi,

Nextcloud-server seems to be gone on Xenial.

sudo apt-cache search nextcloud
nextcloud-client - Nexcloud desktop synchronization client


#49

Updated repository for Stretch and Jessie.

nextcloud-server 12.0.4
nextcloud-client 2.3.3

Enjoy :slight_smile:


#50

Updated repository for Stretch and Jessie.

nextcloud-server 12.0.5

Lot changes from 12.0.4 to 12.0.5 and strongly recommend to make update.


#51

Updated repository for Stretch and Jessie.

nextcloud-server 13.0.0

Example of upgrade 12.0.5 to 13.0.0


#52

It seems @morph027 no longer updates packages, perhaps I should link to you, @ijurisic ?? OK with that?

I guess it isn’t possible to create one repo where you both work on and where others can contribute… Having a public and maintained-with-multiple-people repo would be nicest…


#53

Hi!

I’m just happy with a one-time extract and then use the updater :wink:

But of course, multiple maintainers would be great. I will check for options where to host. Launchpad was to bogus to me last time i’ve tried, probably opensuse build service.


#54

Updated repository for Stretch and Jessie.

nextcloud-server 13.0.2

Example of upgrade 13.0.1 to 13.0.2

p.s. - @morph027 I open for collaboration :grinning:


#55

Updated repository for Stretch and Jessie.

nextcloud-server 13.0.4

Example of upgrade.


#56

Packages for Jessie and Stretch is upgraded from 13.0.4 to 13.0.5


#57

Hey, seems the nextcloud-server package depends on some unneeded packages. I already have a working install, and yet it wants to pull in these additional packages:

libpq5 php7.0-cgi php7.0-ldap php7.0-pgsql php7.0-sqlite3

Presumably it should use an ‘or’ for the database connections, so it would depend on “php-mysql | php-pgsql | php-sqlite3”.

php-cgi should probably be replaced with “php-fpm | php-cgi”. Note the description of the php-cgi package:

Note that MOST users probably want the php7.0-fpm package.

php-ldap is not required, would be better in the recommends section.

Thanks for maintaining this repository.


#58

@Dreamsorcerer - Your suggestion is for package Jessie or Stretch?


#59

Stretch please.


#60

I move from “Depends” to:

Recommends: php7.0-ldap, php7.0-pgsql, php7.0-sqlite3
Suggests: php7.0-cgi