Spelling Check CODE 3.0


Installed collabora online development edition

  • LOOLWSD 3.0.0 (git hash: 81c8935)
  • LOKit Collabora Office 5.3-36 (git hash: bb5e55d)

but the spelling check function is not working.
It just show “none (do not check spelling)”.

How can I enable the spelling check?


My guess is that you installed the regular code package from repository, as the docker instance has all spell check pre installed.
I bumped into this also:
Collabora Online 3.0 out with full-featured editing dialogs

Depending on what distro you run, you can install hunspell packages for the languages you need.
As a collabora developer notes:
Tools -> Language for .... is showing code instead of options

It apears that hunspell should be used instead of myspell

LOKit Collabora Office loads dictionaries deom /usr/share/hunspell. You can install dictionary packages, or you can copy .dic and .aff files manually there. The file names should be proper language tags, otherwise the name might not be recognized.

In case of the CODE docker image, the internal hunspell disctionaries from Collabora Office are copied (with proper names) to /usr/share/hunspell. See https://github.com/CollaboraOnline/Docker-CODE/blob/6c5588a344970a94a11f1ef08a383423f7e07c43/scripts/install-libreoffice.sh#L20


Thanks for pointing to your github repo and the install script.
I just used information from https://www.collaboraoffice.com/code/ for Ubuntu.
That’s why i ended up missing stuff.

But now following your script i installed:
hunspell-de-de hunspell-en-us hunspell-en-gb hunspell-fr hunspell-nl

I rather install the hunspell packages from repo so for me no manual copy of files is needed.
All issues fixed now, also the other issue with the dialog language :+1:

Perhaps the info on your main page can be expanded so that the extra packages and files form the script are installed, or a link to your script for reference.

Thank you all!

apt-get install collaboraoffice5.3-dict-en
apt-get install collaboraofficebasis5.3-en
apt-get install hunspell
apt-get -y install locales-all
systemctl restart loolwsd.service

The spelling check function is working now.

But here comes another issue:

For example: two misspelling words
Screenshot at 2017-12-29 10-15-19

Try to correct the first one, the “firrst” is in red color and suggestion show “first”.

then, after clicked the “Correct” button

“seconnd” does not turn red, but the suggestion field shows the correct one.

It seems that “Not in dictionary” field is not updating.

It seems cache problem of the browser, after clear all caches and reload the page, it works.
Sorry for bothering!

I had the same issue and is solved following your indications.
Thanks a lot!


I have the univention code docker vers. In this version there are only GB english and USA english spellchecking.
How can I add additional dictionaries into docker?


By default only limited set of spelling dictionaries and thesauri are configured for CODE, mainly for performance reasons. The default set of languages is the following: de_DE en_GB en_US es_ES fr_FR it nl pt_BR pt_PT ru.

You can change this list with dictionaries environment variable, when you start docker, or you can change the config file /etc/loolwsd/loölwsd.conf.

Hello timar,

Since I do not know how to modify the docker settings onmy univention code docker container I tried second method:
I went into my code docker container and tried to modify the loolwsd.conf, but there is no such file. There is only a loolwsd.xml

Ok, have to modify the loolwsd.xml but there is no editor (nano or vim) in my container.
Ist it possible to install it (apt-get is not working)
Best regards,

What would the syntax for that be? And is this an ordered list? I’d like documents to default to en_GB rather than de and I haven’t managed to make this happen yet. Setting the language using the occ command line / config/config.php file doesn’t appear to make a difference:

occ config:system:set default_language --value="en_GB"

My bad, sorry. It’s loolwsd.xml of course.

First apt update, then apt install vim should work.

You can pass environment variable dictionaries to docker:
docker run <...> -e "dictionaries=de_DE en_GB en_US es_ES fr_FR it" <...>
The list is unordered.

Currently you can’t do that easily. The ODF template files are from Nextcloud core, and they are German for historical reasons. Soon, there will be a better template management. But for now, you can change the language of the whole document from the CODE menu.

1 Like